summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authormatoro <matoro@users.noreply.github.com>2022-06-15 00:24:24 -0400
committerMatt Turner <mattst88@gentoo.org>2022-10-22 17:33:10 -0400
commit99ff61135ab3c7b66cf72ec78ae2d0e4bd852aa7 (patch)
tree0fc50aab2fb1ef49615cff0dff1c4e616f18d6ac /dev-ruby
parentwww-apps/piwigo: add 13.1.0 (diff)
downloadgentoo-99ff61135ab3c7b66cf72ec78ae2d0e4bd852aa7.tar.gz
gentoo-99ff61135ab3c7b66cf72ec78ae2d0e4bd852aa7.tar.bz2
gentoo-99ff61135ab3c7b66cf72ec78ae2d0e4bd852aa7.zip
dev-ruby/async-container: new package, add 0.16.12
Signed-off-by: matoro <matoro@users.noreply.github.com> Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/async-container/Manifest1
-rw-r--r--dev-ruby/async-container/async-container-0.16.12.ebuild39
-rw-r--r--dev-ruby/async-container/metadata.xml11
3 files changed, 51 insertions, 0 deletions
diff --git a/dev-ruby/async-container/Manifest b/dev-ruby/async-container/Manifest
new file mode 100644
index 000000000000..aaa698db3399
--- /dev/null
+++ b/dev-ruby/async-container/Manifest
@@ -0,0 +1 @@
+DIST async-container-0.16.12.tar.gz 22626 BLAKE2B 8e850ebededcc0110a8ddf79c23287d816973fee1c32b7e7b76a7158995ffca5476d8701b3b4499aa3c0fd023ee9f253e4d07bc9ad0562a32d529678d0569701 SHA512 d71bdd1dc22a7ebecd4fed7e17b28c9ae1c875e111db4fb9cddda3508113e3cb7fc72b820c447cac27f047606d20f62180b203e58164da18dc47cff385262441
diff --git a/dev-ruby/async-container/async-container-0.16.12.ebuild b/dev-ruby/async-container/async-container-0.16.12.ebuild
new file mode 100644
index 000000000000..bacc76a095b5
--- /dev/null
+++ b/dev-ruby/async-container/async-container-0.16.12.ebuild
@@ -0,0 +1,39 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+USE_RUBY="ruby26 ruby27 ruby30 ruby31"
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+RUBY_FAKEGEM_EXTRADOC="README.md"
+RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
+inherit ruby-fakegem
+
+DESCRIPTION="Abstract container-based parallelism using threads and processes"
+HOMEPAGE="https://github.com/socketry/async-container"
+SRC_URI="https://github.com/socketry/async-container/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="$(ver_cut 1)/$(ver_cut 1-2)"
+KEYWORDS="~amd64 ~sparc"
+IUSE=""
+
+ruby_add_rdepend "dev-ruby/async
+ dev-ruby/async-io"
+
+ruby_add_bdepend "test? (
+ dev-ruby/bundler
+ >=dev-ruby/async-rspec-1.1:1
+)"
+
+all_ruby_prepare() {
+ sed -i -E 's/require_relative "(.+)"/require File.expand_path("\1")/g' "${RUBY_FAKEGEM_GEMSPEC}" || die
+
+ # spec/async/container/notify/pipe_spec.rb directly executes "bundler" command,
+ # so we can't just wipe out gems.rb as usual. also must remove covered from gemspec
+ # for this reason.
+ sed -i -E 's/gem ".+"//g' "gems.rb" || die
+ sed -i -E 's/spec.add_development_dependency "covered"//g' "${RUBY_FAKEGEM_GEMSPEC}" || die
+
+ sed -i -E 's/require '"'"'covered\/rspec'"'"'//g' "spec/spec_helper.rb" || die
+}
diff --git a/dev-ruby/async-container/metadata.xml b/dev-ruby/async-container/metadata.xml
new file mode 100644
index 000000000000..4f03304084d0
--- /dev/null
+++ b/dev-ruby/async-container/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>ruby@gentoo.org</email>
+ <name>Gentoo Ruby Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">socketry/async-container</remote-id>
+ </upstream>
+</pkgmetadata>