summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2023-04-26 22:09:35 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2023-04-26 22:11:26 -0500
commit9a2a8fd9585f90578a17d379a9698c82cdbc16bc (patch)
tree817fbf0718ae687aeb1baeab32e45739960ce802 /dev-ruby
parentapp-admin/puppetserver: add 8.0.0 (diff)
downloadgentoo-9a2a8fd9585f90578a17d379a9698c82cdbc16bc.tar.gz
gentoo-9a2a8fd9585f90578a17d379a9698c82cdbc16bc.tar.bz2
gentoo-9a2a8fd9585f90578a17d379a9698c82cdbc16bc.zip
dev-ruby/puppetdb-termini: add 8.0.0
Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/puppetdb-termini/Manifest1
-rw-r--r--dev-ruby/puppetdb-termini/puppetdb-termini-8.0.0.ebuild28
2 files changed, 29 insertions, 0 deletions
diff --git a/dev-ruby/puppetdb-termini/Manifest b/dev-ruby/puppetdb-termini/Manifest
index b7aaa8507b5c..139ce6d4210a 100644
--- a/dev-ruby/puppetdb-termini/Manifest
+++ b/dev-ruby/puppetdb-termini/Manifest
@@ -1,2 +1,3 @@
DIST puppetdb-termini_7.12.1-1bullseye_all.deb 22644 BLAKE2B 16c62aafca8ea2a1f04e6e3708bd1354262dcfdc2afd085e4ef2c949409e4ed9a21fb965b9b67099024d9027b996bdbbc3bf16bbdf92f6cfa6e8d0b4b7c60c90 SHA512 4fd214c02e71a038ba52b2cc2ad33172ab5a13739e831fa1f53fbba45b7f19644104fe06cd12c796eb81556dcf9c5221cd9341d55a4b803c5d005f1da4deca46
DIST puppetdb-termini_7.13.0-1bullseye_all.deb 22548 BLAKE2B 535a3f846a7a10dcfaec4447ae852c6c4d870a573169f84e31f61c361164caea989f911df2d18e183c391dd0130a10b9422057eecaab304bebbb022f78e22a21 SHA512 3c8e440bfc55579d0c9a03ecae516d4cef49512ad9fdd6fceef37618c163ecac6d77a2b17b6cbb7131ceb3787904486bb78eef84a36a5f76672918db6d30db86
+DIST puppetdb-termini_8.0.0-1focal_all.deb 21796 BLAKE2B 6065bf41cf173e36ecf3b5d8bb64d92e62e2f6b2ed1d203e294768f1af0bbd735906b57c762df512fed23582d4b67b7abc45b39831e4398a8fadf068b77c5ad8 SHA512 6a8e3423894ca45847e91dc444cb4910f5d8bae194a413054a305ec21fad9ae52fb26324755f633b5df7c2be38c77ef7549b2fc4cb2894530314dd3f32900447
diff --git a/dev-ruby/puppetdb-termini/puppetdb-termini-8.0.0.ebuild b/dev-ruby/puppetdb-termini/puppetdb-termini-8.0.0.ebuild
new file mode 100644
index 000000000000..dfbabaa8b2cd
--- /dev/null
+++ b/dev-ruby/puppetdb-termini/puppetdb-termini-8.0.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+USE_RUBY="ruby26 ruby27 ruby30 ruby31"
+
+inherit unpacker
+
+DESCRIPTION="Library needed to connect puppet to puppetdb"
+HOMEPAGE="https://puppet.com/docs/puppetdb/latest/index.html"
+SRC_URI="http://apt.puppetlabs.com/pool/focal/puppet8/${PN:0:1}/${PN}/${PN}_${PV}-1focal_all.deb"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE=""
+# will need the same keywords as puppet
+KEYWORDS="~amd64 ~arm64 ~ppc ~x86"
+
+RDEPEND+=""
+DEPEND+=""
+
+S=${WORKDIR}
+
+src_install() {
+ insinto opt/puppetlabs/puppet/lib/ruby/vendor_ruby/puppet/
+ doins -r opt/puppetlabs/puppet/lib/ruby/vendor_ruby/puppet/*
+}