summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2019-08-07 06:59:33 +0200
committerHans de Graaff <graaff@gentoo.org>2019-08-07 07:10:19 +0200
commit9cf3ac0cd5c1f7391a368b5a832a95fc1d6e3573 (patch)
tree65c8a060442ec9f35dcaa36e334ac3ba084dc637 /dev-ruby
parentdev-ruby/google-protobuf: add 3.9.1 (diff)
downloadgentoo-9cf3ac0cd5c1f7391a368b5a832a95fc1d6e3573.tar.gz
gentoo-9cf3ac0cd5c1f7391a368b5a832a95fc1d6e3573.tar.bz2
gentoo-9cf3ac0cd5c1f7391a368b5a832a95fc1d6e3573.zip
dev-ruby/rexical: add 1.0.7
Package-Manager: Portage-2.3.69, Repoman-2.3.16 Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/rexical/Manifest1
-rw-r--r--dev-ruby/rexical/rexical-1.0.7.ebuild35
2 files changed, 36 insertions, 0 deletions
diff --git a/dev-ruby/rexical/Manifest b/dev-ruby/rexical/Manifest
index abb38e91813c..232ad795b1d6 100644
--- a/dev-ruby/rexical/Manifest
+++ b/dev-ruby/rexical/Manifest
@@ -1 +1,2 @@
DIST rexical-1.0.5.gem 20480 BLAKE2B 6ed81f9247410aa68cec1ad02a49774da839679fa3f535691f79da42144fbcda4b0f0dac74c7c02bb08d262b66bd543a8bde05ac5871454b96a7582c228e5fff SHA512 6cf5eac36953203a2de66eccbbc8679a4d695c3f0540ab8adf7a3db37eb4e94889c64c3ce4e4e88ea52738a6733680be2105e0604d01a2e07bae10939deb03c1
+DIST rexical-1.0.7.gem 22016 BLAKE2B aaadf4131fbc4958a6a17be02b970070e511dcb031fd6432fb62fb841eff36b4d5c41d8f8f295aed4ac376c49e736e5d795166f71957578c6cbe14fd6cea26be SHA512 f71c86bd9764e65ebe0c66acd5446b5da7a1b38aae9d33367d70bfa253eb53c178634ce90c883c5459622219670d4d32f375b216c3023a3109329d6930dec1fc
diff --git a/dev-ruby/rexical/rexical-1.0.7.ebuild b/dev-ruby/rexical/rexical-1.0.7.ebuild
new file mode 100644
index 000000000000..20780aa4eacb
--- /dev/null
+++ b/dev-ruby/rexical/rexical-1.0.7.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+USE_RUBY="ruby24 ruby25 ruby26"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.rdoc DOCUMENTATION.en.rdoc DOCUMENTATION.ja.rdoc README.ja README.rdoc"
+
+inherit ruby-fakegem eutils
+
+DESCRIPTION="Rexical is a lexical scanner generator"
+HOMEPAGE="https://github.com/tenderlove/rexical/tree/master"
+LICENSE="LGPL-2" # plus exception
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+SLOT="0"
+IUSE=""
+
+# File collision, bug 459116
+RDEPEND+=" !!app-admin/rex"
+
+ruby_add_bdepend "
+ test? (
+ dev-ruby/hoe
+ dev-ruby/minitest
+ )"
+
+all_ruby_install() {
+ all_fakegem_install
+
+ docinto examples
+ dodoc sample/* || die
+}