summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2024-01-19 09:08:22 +0100
committerHans de Graaff <graaff@gentoo.org>2024-01-19 09:08:48 +0100
commita7f2e4ff4441fa5ddaf7ba14edb6487e3791bf3b (patch)
tree23f591820107c8f59d39814a63e0c848ae93ebc8 /dev-ruby
parentdev-ruby/bigdecimal: add 3.1.6 (diff)
downloadgentoo-a7f2e4ff4441fa5ddaf7ba14edb6487e3791bf3b.tar.gz
gentoo-a7f2e4ff4441fa5ddaf7ba14edb6487e3791bf3b.tar.bz2
gentoo-a7f2e4ff4441fa5ddaf7ba14edb6487e3791bf3b.zip
dev-ruby/io-console: add 0.7.2
Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/io-console/Manifest1
-rw-r--r--dev-ruby/io-console/io-console-0.7.2.ebuild43
2 files changed, 44 insertions, 0 deletions
diff --git a/dev-ruby/io-console/Manifest b/dev-ruby/io-console/Manifest
index 4c1e1a000d50..2eb98c4e2fce 100644
--- a/dev-ruby/io-console/Manifest
+++ b/dev-ruby/io-console/Manifest
@@ -1,3 +1,4 @@
DIST io-console-0.6.0.tar.gz 45358 BLAKE2B 0de9eabbc2dd218e7ff367d970133080eda36178f35655c392ba6ab73866cb7fba09fd26a16062ef1f1bab1fb941486f13e277589aa98954612d4593421afcff SHA512 25e6fc318c51dc9f8daf5743340505eea7c5364b1787862464bfb45afb99c7c7ac8c55caf1f53c5fb5921269f3827262f17449f110efbcc44f7364235563959d
DIST io-console-0.7.0.tar.gz 36264 BLAKE2B 3cd627d8847fdfe37a95c68745b2328e9900e749e018d169f3261f8c52d4bd426b95aa833d21d1cd5a822c1caee3eb1decd1e7ab243414dd9685d4ead80d5025 SHA512 3e10df57a20903e16870526c890a8a2fc428de3f40d7a712dd1dc64fe5e9a7a69bd9ca820828e103f96aba681d05149a01167a7ee92e288283a633e333637973
DIST io-console-0.7.1.tar.gz 36269 BLAKE2B 408579b41ad89e6ba744b4fdb84f9d17a6605c1ee7990f156e40f8276b7cbaeddf665e9d70b214685a7348797f55d789628ffd3ed0ed2c6c1b03621ab59c94eb SHA512 51b18cb47ee2884f98fe1df0656fbd85853629c06f7b82835767e1fa896013e1899dee154a7a52d7b5f3c48933a7e45550bd7f203f0b01320531c29c3554e1c8
+DIST io-console-0.7.2.tar.gz 37259 BLAKE2B 22f5f3cfedf477affa1452ce7eab862d49da1943255545f15dd519f7029e61b8747341606ebc1da7bbb020ba5f0ec7e48d08ab000da3b7192cf42ceb601b0b7c SHA512 1dd99c8e9681436a68f39f89f6104a45db2d17092f64985e36a7cd37418831b81f2749922e16ee43a633a90466a8916327a7f21249ceae2f889e70ae596c5b3b
diff --git a/dev-ruby/io-console/io-console-0.7.2.ebuild b/dev-ruby/io-console/io-console-0.7.2.ebuild
new file mode 100644
index 000000000000..ff029407fd12
--- /dev/null
+++ b/dev-ruby/io-console/io-console-0.7.2.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby31 ruby32 ruby33"
+
+RUBY_FAKEGEM_EXTENSIONS=(ext/io/console/extconf.rb)
+RUBY_FAKEGEM_EXTENSION_LIBDIR="lib/io"
+RUBY_FAKEGEM_EXTRADOC="README.md"
+RUBY_FAKEGEM_GEMSPEC="io-console.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="add console capabilities to IO instances"
+HOMEPAGE="https://github.com/ruby/io-console"
+SRC_URI="https://github.com/ruby/io-console/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x64-solaris"
+IUSE="test"
+
+ruby_add_bdepend "test? ( dev-ruby/test-unit dev-ruby/test-unit-ruby-core )"
+
+all_ruby_prepare() {
+ sed -e 's/__FILE__/"'${RUBY_FAKEGEM_GEMSPEC}'"/' \
+ -e 's/__dir__/"."/' \
+ -e 's/git ls-files -z/find * -print0/' \
+ -i ${RUBY_FAKEGEM_GEMSPEC} || die
+ sed -e '/task :test/ s:^:#:' -i Rakefile || die
+
+ # Avoid test that require a proper TTY
+ sed -e '/test_\(bad_keyword\|failed_path\)/aomit "requires TTY"' \
+ -i test/io/console/test_io_console.rb || die
+
+ # Remove ruby and ffi files in accordance with the gemspec. These
+ # are only used when using a different ruby engine like jruby.
+ rm -fr lib/io/console.rb lib/io/console/ffi || die
+}
+
+each_ruby_test() {
+ ${RUBY} -Ilib:.:test:test/lib -rhelper -e 'Dir["test/**/test_*.rb"].each{|f| require f}' || die
+}