summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2022-01-22 18:53:28 -0600
committerMatthew Thode <prometheanfire@gentoo.org>2022-01-22 18:59:05 -0600
commita8ea7a5630c67ee000366e7ae86287951072f88d (patch)
treeb6691d5de87af2c03d0455ba10f28b2d288ef875 /dev-ruby
parentapp-admin/puppet-agent: 7.14.0 bump, adding arm64 keyword (diff)
downloadgentoo-a8ea7a5630c67ee000366e7ae86287951072f88d.tar.gz
gentoo-a8ea7a5630c67ee000366e7ae86287951072f88d.tar.bz2
gentoo-a8ea7a5630c67ee000366e7ae86287951072f88d.zip
dev-ruby/puppetdb-termini: 7.9.0 bump
Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/puppetdb-termini/Manifest1
-rw-r--r--dev-ruby/puppetdb-termini/puppetdb-termini-7.9.0.ebuild28
2 files changed, 29 insertions, 0 deletions
diff --git a/dev-ruby/puppetdb-termini/Manifest b/dev-ruby/puppetdb-termini/Manifest
index 3e0cbe0069fc..3cf7c01e7b08 100644
--- a/dev-ruby/puppetdb-termini/Manifest
+++ b/dev-ruby/puppetdb-termini/Manifest
@@ -1,2 +1,3 @@
DIST puppetdb-termini_7.7.0-1stretch_all.deb 22018 BLAKE2B 38716d2fe7bbe14656e4f274096ae93d4dc316cbdca49a0da33061df87666caea2bb8fa855de7539be8355805cb5055f74339b12660fe4f8020dbc0f92b79fdf SHA512 61c70aa919a6cee85a36e50c122ed7570e996fb74f68f70733d3f2233dcbbce8623090e9d856722c0da8583836457ded11cd97d1492019a84df00855fe79d462
DIST puppetdb-termini_7.8.0-1stretch_all.deb 22012 BLAKE2B f084e99db0948bf290b0b37e27e206d2929214b9b071b9681a5b8cfa4a153d4c35f5d00be5a50a24af669619080db5ccf9d2a16c62d767a457db344f347e2811 SHA512 4b7b3535e85f353ad1d120e3699ddd76b42c23bd9a93eb06403dcf8cc50697512c097d2fe23495fe676c97993ea535a26a752f02fd9e8203073a09bf018d12c1
+DIST puppetdb-termini_7.9.0-1stretch_all.deb 21860 BLAKE2B e2ecc32f216a22d1c617d9d407d58512a2d84e2eb73ed37425ed16abc7948a8e6b8a0744798baf4282b5d43605e66cc8f5fb59e42eaffe10625d486e120e8d71 SHA512 e91cd0870d02fb690c0d9585b9d56b72e53c5f64ab5bec4631651326806a270f0c6601c77279d17b5182d73924a3782f2e1ca5fdf4cf03beac1b0e3e807b36db
diff --git a/dev-ruby/puppetdb-termini/puppetdb-termini-7.9.0.ebuild b/dev-ruby/puppetdb-termini/puppetdb-termini-7.9.0.ebuild
new file mode 100644
index 000000000000..a2bc85cce4e6
--- /dev/null
+++ b/dev-ruby/puppetdb-termini/puppetdb-termini-7.9.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+USE_RUBY="ruby25 ruby26 ruby27"
+
+inherit unpacker
+
+DESCRIPTION="Library needed to connect puppet to puppetdb"
+HOMEPAGE="https://puppet.com/docs/puppetdb/latest/index.html"
+SRC_URI="http://apt.puppetlabs.com/pool/stretch/puppet/${PN:0:1}/${PN}/${PN}_${PV}-1stretch_all.deb"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE=""
+# will need the same keywords as puppet
+KEYWORDS="~amd64 ~arm64 ~ppc ~x86"
+
+RDEPEND+=""
+DEPEND+=""
+
+S=${WORKDIR}
+
+src_install() {
+ insinto opt/puppetlabs/puppet/lib/ruby/vendor_ruby/puppet/
+ doins -r opt/puppetlabs/puppet/lib/ruby/vendor_ruby/puppet/*
+}