summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2020-06-12 07:48:20 +0200
committerHans de Graaff <graaff@gentoo.org>2020-06-12 07:48:20 +0200
commitb9cf7c32689af6d83490d477dcab72b1438a659a (patch)
treee15664c15d45a71291b24d24db26b0c01a6b104f /dev-ruby
parentdev-ruby/xdr: add 3.0.1 (diff)
downloadgentoo-b9cf7c32689af6d83490d477dcab72b1438a659a.tar.gz
gentoo-b9cf7c32689af6d83490d477dcab72b1438a659a.tar.bz2
gentoo-b9cf7c32689af6d83490d477dcab72b1438a659a.zip
dev-ruby/sexp_processor: add 4.15.0
Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/sexp_processor/Manifest1
-rw-r--r--dev-ruby/sexp_processor/sexp_processor-4.15.0.ebuild28
2 files changed, 29 insertions, 0 deletions
diff --git a/dev-ruby/sexp_processor/Manifest b/dev-ruby/sexp_processor/Manifest
index 67b96960e0b6..04f82a2b8bf1 100644
--- a/dev-ruby/sexp_processor/Manifest
+++ b/dev-ruby/sexp_processor/Manifest
@@ -3,3 +3,4 @@ DIST sexp_processor-4.12.1.gem 54784 BLAKE2B 95b238abb3050448cd076cfbda61d60c1d2
DIST sexp_processor-4.13.0.gem 55808 BLAKE2B d807f632e93bbffaf92c31214a5d76fb5f069563af07f3f3c9d8095114d4ffc41a759144f93e1081d4192e6b7d572feab2be10a5fd639bafc0d3b166a4d5b5e1 SHA512 0b83613c10dd268837bddd552910c799e002eea6b409aa9788a5a65957454d2ef601cc023f84d98dbacc34e3c58923d6c43115510bae7ec9d2d72286f141828a
DIST sexp_processor-4.14.0.gem 55808 BLAKE2B 60e19163bfca60b019b462f251eddc1f3644207f8eb4ac6240cb5eec9365621c56bd0a6741d1371a502c745b41e6a5efa29323a43ce919d823c0f11fd1a4d6f5 SHA512 90a6ed905d79079b51849521e25d8e6aa87c8d9aced75883b4080568a30aa3c349df35bb74556a1755f77ed73d3260ce88534d1967db93b39b34cf28132e0093
DIST sexp_processor-4.14.1.gem 56320 BLAKE2B 86b4ca1f766d224fcaa83cf24df3db00d1790cb8d84cdc17fa427143d1a06b0ae3fa752994f528f5b4ddced04fb285af3c0d30e6227d84188b26dbf7a0a7625f SHA512 2a693afd2eb478360d06b59191a98f6590f6bfaba79dd931c6c7b1f5d6b511ec899e804c9826ce054ed3d625ab74dc775583167e0ff560713c6481785e31b8b3
+DIST sexp_processor-4.15.0.gem 56320 BLAKE2B 8624b7fe28f4aa9447f42cf4f8c5b424088ca2c1628f3e785f746ceb60725449812205dc657ea856c5bead616ac18d689330315fdb44e92447ee3a89740557d1 SHA512 f7877ca59191ab39848c6d3b0cf9625c2e1c180784cd757c00a7cea67aa6eee5549ab5630641f4044c875a1aaadc89b8237f8adadc961ed86c5379cb72db33c3
diff --git a/dev-ruby/sexp_processor/sexp_processor-4.15.0.ebuild b/dev-ruby/sexp_processor/sexp_processor-4.15.0.ebuild
new file mode 100644
index 000000000000..19ab7bf0b4c2
--- /dev/null
+++ b/dev-ruby/sexp_processor/sexp_processor-4.15.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+USE_RUBY="ruby25 ruby26 ruby27"
+
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="README.rdoc History.rdoc"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Processor for s-expressions created as part of the ParseTree project"
+HOMEPAGE="https://www.zenspider.com/projects/sexp_processor.html"
+
+LICENSE="GPL-2"
+SLOT="4"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+ruby_add_bdepend "
+ test? (
+ >=dev-ruby/minitest-5.5
+ )"
+
+each_ruby_test() {
+ ${RUBY} -Ilib:. -e 'Dir["test/test_*.rb"].each{|f| require f}' || die
+}