summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2023-05-13 06:41:51 +0200
committerHans de Graaff <graaff@gentoo.org>2023-05-13 07:07:45 +0200
commitc30c363909c5164a285740109f656981b95ed2e4 (patch)
treeef89d8b44ca64baef9632b8d609c14c258bee334 /dev-ruby
parentsys-cluster/torque: Fix register storage class specifier not allowed (diff)
downloadgentoo-c30c363909c5164a285740109f656981b95ed2e4.tar.gz
gentoo-c30c363909c5164a285740109f656981b95ed2e4.tar.bz2
gentoo-c30c363909c5164a285740109f656981b95ed2e4.zip
dev-ruby/test-unit: add 3.5.8
Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/test-unit/Manifest1
-rw-r--r--dev-ruby/test-unit/test-unit-3.5.8.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/dev-ruby/test-unit/Manifest b/dev-ruby/test-unit/Manifest
index 3d86c1b0bbc4..80af02b7a9c6 100644
--- a/dev-ruby/test-unit/Manifest
+++ b/dev-ruby/test-unit/Manifest
@@ -1 +1,2 @@
DIST test-unit-3.5.7.tar.gz 164734 BLAKE2B 470a4552f2da0b7b9c8f3cbd071229fefa12c1e48c32936a6520902a9443a891cd19ed0e7c71ba4f8d81747902afd2e3dbc3eaa6ac7683ca11e5ad88e7c4497e SHA512 af678a89590c9305eeac3a4e5c7e99354df5b49157de573ee3ff312dad9f12dbcaef3dfe7ffc256194e39e0438625acdd9ab3e9686d7e2c58b2cf225f7f1f74c
+DIST test-unit-3.5.8.tar.gz 165216 BLAKE2B 1a039931d87ce3ad4afecd4c1105bb6197acc05be3b9091ca6361689f42d725d1333553b7527bc5cb46306acd3ac4df20ed809e0aca9928a760fc0d849a51e2b SHA512 ab7f492dd5f4606cd91a32240aa3ef6dffec48281b65d960bf87d0b2a9a865d6273bb4cc6896397136c5b313669f615fe6f5a83a6a4ab241013eaa51cf5e3341
diff --git a/dev-ruby/test-unit/test-unit-3.5.8.ebuild b/dev-ruby/test-unit/test-unit-3.5.8.ebuild
new file mode 100644
index 000000000000..35292fb09beb
--- /dev/null
+++ b/dev-ruby/test-unit/test-unit-3.5.8.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby30 ruby31 ruby32"
+
+RUBY_FAKEGEM_EXTRADOC="README.md doc-install/text/*.md"
+
+RUBY_FAKEGEM_GEMSPEC="test-unit.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="An xUnit family unit testing framework for Ruby"
+HOMEPAGE="https://rubygems.org/gems/test-unit"
+SRC_URI="https://github.com/test-unit/test-unit/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="|| ( Ruby-BSD BSD-2 ) PSF-2"
+SLOT="2"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="doc test"
+
+ruby_add_rdepend "dev-ruby/power_assert"
+
+all_ruby_prepare() {
+ mv doc doc-install || die "moving doc directory out of the way failed"
+}
+
+each_ruby_test() {
+ ${RUBY} test/run-test.rb || die "testsuite failed"
+}
+
+all_ruby_install() {
+ all_fakegem_install
+
+ newbin "${FILESDIR}"/testrb-3 testrb-2
+}