summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2022-07-23 08:46:47 +0200
committerHans de Graaff <graaff@gentoo.org>2022-07-23 09:18:15 +0200
commitc4b219c4cb00d9740a855847aa3210a5789f5ce7 (patch)
treea458bdf898a02338cc16112f0df305d9147bc5d8 /dev-ruby
parentapp-admin/chroot_safe: keyword 1.4-r1 for ~riscv (diff)
downloadgentoo-c4b219c4cb00d9740a855847aa3210a5789f5ce7.tar.gz
gentoo-c4b219c4cb00d9740a855847aa3210a5789f5ce7.tar.bz2
gentoo-c4b219c4cb00d9740a855847aa3210a5789f5ce7.zip
dev-ruby/tilt: add 2.0.11
Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/tilt/Manifest1
-rw-r--r--dev-ruby/tilt/tilt-2.0.11.ebuild42
2 files changed, 43 insertions, 0 deletions
diff --git a/dev-ruby/tilt/Manifest b/dev-ruby/tilt/Manifest
index a9095e87c6a9..b6053ea67cab 100644
--- a/dev-ruby/tilt/Manifest
+++ b/dev-ruby/tilt/Manifest
@@ -1 +1,2 @@
DIST tilt-2.0.10.tar.gz 51446 BLAKE2B de5c12dcf22994f182ae163a82c3060f1d0d8b4bc2a4495f28c9befc954b4949b9d2ae6aed42e3a9c35fb68825844881d9f15b2b68d949236e5396083ff199a3 SHA512 4a36c55347e307ea0c842aad3da72cebe98bcf8a0421040cfce7a43540d1746e736ce92b7ce7492a5cfc184372842c3ac7a006f3650b4c9420d5825ec005b4ef
+DIST tilt-2.0.11.tar.gz 53041 BLAKE2B 2509cc3efe5e6302c8943c00108eeda6ee4b23a18952ad23049e11ea28b397b80a21d34c4d241119f45cedf2a978a2673d857a6cc32d7e26a2016caa510458f9 SHA512 e28e31ab92aa42eada34e0f6c05dab6a54945d07b649588356b1635ba8a36700f6e537e8702613883693501442d21690d8b3690b06f7b9f331192134511b78b7
diff --git a/dev-ruby/tilt/tilt-2.0.11.ebuild b/dev-ruby/tilt/tilt-2.0.11.ebuild
new file mode 100644
index 000000000000..e9c9bcc4af48
--- /dev/null
+++ b/dev-ruby/tilt/tilt-2.0.11.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+USE_RUBY="ruby27 ruby30 ruby31"
+
+RUBY_FAKEGEM_RECIPE_DOC="none"
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md docs/TEMPLATES.md"
+
+RUBY_FAKEGEM_GEMSPEC="tilt.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Thin interface over template engines to make their usage as generic as possible"
+HOMEPAGE="https://github.com/rtomayko/tilt"
+SRC_URI="https://github.com/rtomayko/tilt/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="2"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+# Block on some of the potential test dependencies. These dependencies
+# are optional for the test suite, and we don't want to depend on all of
+# them to faciliate keywording and stabling.
+ruby_add_bdepend "test? (
+ dev-ruby/erubis
+ dev-ruby/nokogiri
+)"
+
+all_ruby_prepare() {
+ rm Gemfile || die
+ sed -e '/bundler/I s:^:#:' -i Rakefile test/test_helper.rb || die
+
+ # Avoid tests with minor syntax differences since this happens all
+ # the time when details in the dependencies change.
+ rm -f test/tilt_sasstemplate_test.rb || die
+
+ # Skip tests for unpackaged asciidoctor converter
+ sed -i -e '/docbook 4.5/askip' test/tilt_asciidoctor_test.rb || die
+}