summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2022-03-20 07:52:18 +0100
committerHans de Graaff <graaff@gentoo.org>2022-03-20 11:04:34 +0100
commite8b1469f82bf2feb4f92e96a05959deca547ccb2 (patch)
tree239005edb706dfbb764807775332592aec5a7762 /dev-ruby
parentdev-ruby/activesupport: add ruby30 (diff)
downloadgentoo-e8b1469f82bf2feb4f92e96a05959deca547ccb2.tar.gz
gentoo-e8b1469f82bf2feb4f92e96a05959deca547ccb2.tar.bz2
gentoo-e8b1469f82bf2feb4f92e96a05959deca547ccb2.zip
dev-ruby/tilt: add ruby30
Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/tilt/files/tilt-2.0.10-ruby30.patch37
-rw-r--r--dev-ruby/tilt/tilt-2.0.10-r1.ebuild46
2 files changed, 83 insertions, 0 deletions
diff --git a/dev-ruby/tilt/files/tilt-2.0.10-ruby30.patch b/dev-ruby/tilt/files/tilt-2.0.10-ruby30.patch
new file mode 100644
index 000000000000..27e4d821f64f
--- /dev/null
+++ b/dev-ruby/tilt/files/tilt-2.0.10-ruby30.patch
@@ -0,0 +1,37 @@
+From 91838d57aa35ba5341368ead0d442e1dc1eb8730 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?V=C3=ADt=20Ondruch?= <vondruch@redhat.com>
+Date: Mon, 18 Jan 2021 12:49:31 +0100
+Subject: [PATCH] Fix Ruby 3.0 compatibility.
+
+This fixes issues such as:
+
+~~~
+ 1) Error:
+CSVTemplateTest#test_compiles_and_evaluates_the_template_on_render:
+TypeError: no implicit conversion of Hash into String
+ /usr/share/ruby/csv.rb:1273:in `initialize'
+ /usr/share/ruby/csv.rb:1273:in `new'
+ /usr/share/ruby/csv.rb:1273:in `generate'
+ (__TEMPLATE__):in `__tilt_920'
+ /builddir/build/BUILD/tilt-2.0.10/usr/share/gems/gems/tilt-2.0.10/lib/tilt/template.rb:170:in `call'
+ /builddir/build/BUILD/tilt-2.0.10/usr/share/gems/gems/tilt-2.0.10/lib/tilt/template.rb:170:in `evaluate'
+ /builddir/build/BUILD/tilt-2.0.10/usr/share/gems/gems/tilt-2.0.10/lib/tilt/template.rb:109:in `render'
+ /builddir/build/BUILD/tilt-2.0.10/usr/share/gems/gems/tilt-2.0.10/test/tilt_csv_test.rb:15:in `block in <class:CSVTemplateTest>'
+~~~
+---
+ lib/tilt/csv.rb | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/lib/tilt/csv.rb b/lib/tilt/csv.rb
+index fd0e602..7dfa220 100644
+--- a/lib/tilt/csv.rb
++++ b/lib/tilt/csv.rb
+@@ -50,7 +50,7 @@ def prepare
+
+ def precompiled_template(locals)
+ <<-RUBY
+- #{@outvar} = #{self.class.engine}.generate(#{options}) do |csv|
++ #{@outvar} = #{self.class.engine}.generate(**#{options}) do |csv|
+ #{data}
+ end
+ RUBY
diff --git a/dev-ruby/tilt/tilt-2.0.10-r1.ebuild b/dev-ruby/tilt/tilt-2.0.10-r1.ebuild
new file mode 100644
index 000000000000..00b33d3ba691
--- /dev/null
+++ b/dev-ruby/tilt/tilt-2.0.10-r1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+USE_RUBY="ruby26 ruby27 ruby30"
+
+RUBY_FAKEGEM_RECIPE_DOC="none"
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md docs/TEMPLATES.md"
+
+RUBY_FAKEGEM_GEMSPEC="tilt.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Thin interface over template engines to make their usage as generic as possible"
+HOMEPAGE="https://github.com/rtomayko/tilt"
+SRC_URI="https://github.com/rtomayko/tilt/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="2"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+PATCHES=( "${FILESDIR}/${P}-ruby30.patch" )
+
+# Block on some of the potential test dependencies. These dependencies
+# are optional for the test suite, and we don't want to depend on all of
+# them to faciliate keywording and stabling.
+ruby_add_bdepend "test? (
+ dev-ruby/erubis
+ dev-ruby/nokogiri
+)"
+
+all_ruby_prepare() {
+ rm Gemfile || die
+ sed -e '/bundler/I s:^:#:' -i Rakefile test/test_helper.rb || die
+
+ # Avoid tests with minor syntax differences since this happens all
+ # the time when details in the dependencies change.
+ sed -e '/test_smarty_pants_true/,/^ end/ s:^:#:' \
+ -e '/test_smart_quotes_true/,/^ end/ s:^:#:' -i test/tilt_markdown_test.rb || die
+ sed -e '/smartypants when :smart is set/,/^ end/ s:^:#:' -i test/tilt_rdiscounttemplate_test.rb || die
+
+ # Skip tests for unpackaged asciidoctor converter
+ sed -i -e '/docbook 4.5/askip' test/tilt_asciidoctor_test.rb || die
+}