summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2023-02-04 08:31:40 +0100
committerHans de Graaff <graaff@gentoo.org>2023-02-04 08:31:40 +0100
commitef1358200b12368e1b42facf77653da949d2a367 (patch)
tree9f1b609e123a7eb81f22d1f84c0eef2cf8b15b2a /dev-ruby
parentdev-ruby/commonmarker: add 0.23.8 (diff)
downloadgentoo-ef1358200b12368e1b42facf77653da949d2a367.tar.gz
gentoo-ef1358200b12368e1b42facf77653da949d2a367.tar.bz2
gentoo-ef1358200b12368e1b42facf77653da949d2a367.zip
dev-ruby/concurrent-ruby: add 1.2.0
Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/concurrent-ruby/Manifest1
-rw-r--r--dev-ruby/concurrent-ruby/concurrent-ruby-1.2.0.ebuild38
2 files changed, 39 insertions, 0 deletions
diff --git a/dev-ruby/concurrent-ruby/Manifest b/dev-ruby/concurrent-ruby/Manifest
index 85cb41082024..e4ce11afe701 100644
--- a/dev-ruby/concurrent-ruby/Manifest
+++ b/dev-ruby/concurrent-ruby/Manifest
@@ -1,2 +1,3 @@
DIST concurrent-ruby-1.1.10.tar.gz 6013684 BLAKE2B d271579a49ab52c9c41a7a0a31451775e1cba8ce19486b52a9eb3df7abbc66f7610d31284fc02747a8ee5f429983d8283b6fe92f22b911dcda5bc515da58b48f SHA512 cfb67ce806d1f2a5bae509806247bfefb05c56794741cedcaa7ab6ff708085e374d150e8f46ff8e04dcb0918fde8ab5a593c60550da9ff6dc00af116e123f064
DIST concurrent-ruby-1.1.9.tar.gz 4923746 BLAKE2B 2bfea989db31f17c69ee479091135516e2aeef7ac74234ccea91b2e4b3626395683a7b2ebba1d13cb527903d3d83c51e873bdb859f0ff1983062fea4fa90a1e4 SHA512 243fc20795bcd7399bdf77a9b0db9b0bccb1b05edacf4fbc8f5515f59502300b4033a2a59bfb6adea9befdb20759c9f58bbf0e7744e934c85738085bef714ea6
+DIST concurrent-ruby-1.2.0.tar.gz 1160662 BLAKE2B e05df20596930d46781d718ebcd90c8326d78993ad15a7b7c804e0852bdfb66a955314769c8abdef9bc59c6fb249d81c6f48058751537a399da5846ded97dcbc SHA512 c6dc1a84ac4b176644481c2431d67b2b7e0a47fcb9e3fc3fa0b4ddd102ef65d1d02d5aff2784bb55a194f01a4a5294fc26944da16dea550934a6950caee54a31
diff --git a/dev-ruby/concurrent-ruby/concurrent-ruby-1.2.0.ebuild b/dev-ruby/concurrent-ruby/concurrent-ruby-1.2.0.ebuild
new file mode 100644
index 000000000000..98089791617f
--- /dev/null
+++ b/dev-ruby/concurrent-ruby/concurrent-ruby-1.2.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby27 ruby30 ruby31"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RUBY_FAKEGEM_RECIPE_DOC=""
+
+RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Modern concurrency tools including agents, futures, promises, thread pools, more"
+HOMEPAGE="https://github.com/ruby-concurrency/concurrent-ruby"
+SRC_URI="https://github.com/ruby-concurrency/concurrent-ruby/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="1"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+ruby_add_bdepend "test? ( >=dev-ruby/timecop-0.7.4 )"
+
+all_ruby_prepare() {
+ # Remove edge files as defined in support/file_map.rb
+ rm -rf spec/concurrent/{actor,cancellation,channel,edge,lazy_register,processing,promises,throttle}* || die
+ rm -r spec/concurrent/executor/wrapping_executor_spec.rb || die
+ sed -i -e '/concurrent-edge/ s:^:#:' spec/spec_helper.rb || die
+ sed -i -e 's:lib-edge:lib/concurrent-ruby:' .rspec || die
+ sed -i -e 's:../../../::' spec/concurrent/executor/executor_quits.rb || die
+
+ # Remove specs for the ext gem
+ rm -rf spec/concurrent/atomic || die
+
+ sed -i 's/git ls-files/find * -print/' ${RUBY_FAKEGEM_GEMSPEC} || die
+}