summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2017-06-22 13:44:11 +0200
committerHans de Graaff <graaff@gentoo.org>2017-06-22 13:44:36 +0200
commitf653829e28cdac6e5151d771045e825c8308c6ca (patch)
tree4ced111cdf9ebc0f832da0e8b431c79d40278df5 /dev-ruby
parentdev-ruby/rdoc: marked *-macos (diff)
downloadgentoo-f653829e28cdac6e5151d771045e825c8308c6ca.tar.gz
gentoo-f653829e28cdac6e5151d771045e825c8308c6ca.tar.bz2
gentoo-f653829e28cdac6e5151d771045e825c8308c6ca.zip
dev-ruby/autoprefixer-rails: install javascript file
Package-Manager: Portage-2.3.6, Repoman-2.3.1
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/autoprefixer-rails/autoprefixer-rails-7.1.1.2-r1.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-ruby/autoprefixer-rails/autoprefixer-rails-7.1.1.2-r1.ebuild b/dev-ruby/autoprefixer-rails/autoprefixer-rails-7.1.1.2-r1.ebuild
new file mode 100644
index 000000000000..b9b1a7750c8f
--- /dev/null
+++ b/dev-ruby/autoprefixer-rails/autoprefixer-rails-7.1.1.2-r1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+USE_RUBY="ruby21 ruby22 ruby23"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+RUBY_FAKEGEM_EXTRAINSTALL="vendor"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Add vendor prefixes to CSS rules using values from the Can I Use website"
+HOMEPAGE="https://github.com/ai/autoprefixer-rails"
+LICENSE="MIT"
+
+KEYWORDS="~amd64"
+SLOT="7"
+IUSE=""
+
+ruby_add_rdepend "dev-ruby/execjs:*"
+
+ruby_add_bdepend "dev-ruby/rails
+ dev-ruby/rake
+ dev-ruby/rspec-rails"
+
+all_ruby_prepare() {
+ sed -i -e "/bundler/d" -e "/BUNDLE/d" spec/app/config/boot.rb || die
+ sed -i -e "/Bundler/,+3d" spec/app/config/application.rb || die
+ rm spec/rails_spec.rb spec/compass_spec.rb || die
+}