summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2023-05-16 13:34:53 +0200
committerMaciej Barć <xgqt@gentoo.org>2023-05-16 13:50:43 +0200
commit7e3b8ea2dbbeffdb67ab6b029d2d7349e059d4e4 (patch)
treef7f73c6d4e6e43b2aeeb448d713ce6590df57db2 /dev-scheme/bytestructures/bytestructures-1.0.10.ebuild
parentvirtual/dist-kernel: Remove old (diff)
downloadgentoo-7e3b8ea2dbbeffdb67ab6b029d2d7349e059d4e4.tar.gz
gentoo-7e3b8ea2dbbeffdb67ab6b029d2d7349e059d4e4.tar.bz2
gentoo-7e3b8ea2dbbeffdb67ab6b029d2d7349e059d4e4.zip
dev-scheme: use dostrip instead of RESTRICT
Bug: https://bugs.gentoo.org/905898 Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'dev-scheme/bytestructures/bytestructures-1.0.10.ebuild')
-rw-r--r--dev-scheme/bytestructures/bytestructures-1.0.10.ebuild12
1 files changed, 9 insertions, 3 deletions
diff --git a/dev-scheme/bytestructures/bytestructures-1.0.10.ebuild b/dev-scheme/bytestructures/bytestructures-1.0.10.ebuild
index 4842f26f1ed7..d1268f0666cd 100644
--- a/dev-scheme/bytestructures/bytestructures-1.0.10.ebuild
+++ b/dev-scheme/bytestructures/bytestructures-1.0.10.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -10,8 +10,6 @@ SRC_URI="https://github.com/TaylanUB/scheme-bytestructures/releases/download/v${
LICENSE="LGPL-3+"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE=""
-RESTRICT="strip"
RDEPEND=">=dev-scheme/guile-2.0.0:="
DEPEND="${RDEPEND}"
@@ -34,3 +32,11 @@ src_prepare() {
# http://debbugs.gnu.org/cgi/bugreport.cgi?bug=38112
find "${S}" -name "*.scm" -exec touch {} + || die
}
+
+src_install() {
+ default
+
+ # Workaround llvm-strip problem of mangling guile ELF debug
+ # sections: https://bugs.gentoo.org/905898
+ dostrip -x "/usr/$(get_libdir)/guile"
+}