summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnna (navi) Figueiredo Gomes <navi@vlhl.dev>2023-04-22 15:06:42 -0300
committerMaciej Barć <xgqt@gentoo.org>2023-04-22 20:47:57 +0200
commit0b972be448cb578e54359e649637cb61d447f313 (patch)
treeeeae7db962fbb5ddc5851f866cfc10151f1e3b86 /dev-scheme/elk
parentnet-dialup/ppp: break lines to appease pkgcheck (diff)
downloadgentoo-0b972be448cb578e54359e649637cb61d447f313.tar.gz
gentoo-0b972be448cb578e54359e649637cb61d447f313.tar.bz2
gentoo-0b972be448cb578e54359e649637cb61d447f313.zip
dev-scheme/elk: Patches for implicit-int and ptrs
Closes: https://bugs.gentoo.org/870475 Signed-off-by: Anna (navi) Figueiredo Gomes <navi@vlhl.dev> Closes: https://github.com/gentoo/gentoo/pull/30707 Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'dev-scheme/elk')
-rw-r--r--dev-scheme/elk/elk-3.99.8.ebuild6
-rw-r--r--dev-scheme/elk/files/elk-3.99.8-implicit-int-incompat-ptr.patch52
2 files changed, 57 insertions, 1 deletions
diff --git a/dev-scheme/elk/elk-3.99.8.ebuild b/dev-scheme/elk/elk-3.99.8.ebuild
index a9e62f4c49fe..80e1909b1571 100644
--- a/dev-scheme/elk/elk-3.99.8.ebuild
+++ b/dev-scheme/elk/elk-3.99.8.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -11,6 +11,10 @@ LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64"
+PATCHES=(
+ "${FILESDIR}"/${P}-implicit-int-incompat-ptr.patch
+)
+
src_configure() {
econf --disable-static
}
diff --git a/dev-scheme/elk/files/elk-3.99.8-implicit-int-incompat-ptr.patch b/dev-scheme/elk/files/elk-3.99.8-implicit-int-incompat-ptr.patch
new file mode 100644
index 000000000000..24e91d0a5651
--- /dev/null
+++ b/dev-scheme/elk/files/elk-3.99.8-implicit-int-incompat-ptr.patch
@@ -0,0 +1,52 @@
+--- a/lib/misc/gdbm.c 2011-06-18 07:24:06.000000000 -0300
++++ b/lib/misc/gdbm.c 2023-04-22 14:28:35.200400436 -0300
+@@ -103,7 +103,7 @@
+
+ extern gdbm_error gdbm_errno;
+ extern int errno;
+-static char *gdbm_error_message = "";
++static const char *gdbm_error_message = "";
+
+ static SYMDESCR RW_Syms[] = {
+ { "reader", GDBM_READER },
+@@ -144,7 +144,7 @@
+ return TYPE(x) == T_Gdbm_fh ? True : False;
+ }
+
+-static void Fatal_Func (char *s) {
++static void Fatal_Func (const char *s) {
+ gdbm_error_message = s;
+ fprintf (stderr, "gdbm error: %s\n", s);
+ }
+--- a/src/heap-gen.c 2011-06-18 07:24:06.000000000 -0300
++++ b/src/heap-gen.c 2023-04-22 14:14:51.977052826 -0300
+@@ -872,7 +872,7 @@
+ * determines whether the object is immutable.
+ */
+
+-Object Alloc_Object (size, type, konst) {
++Object Alloc_Object (int size, int type, int konst) {
+ Object obj;
+ register addrarith_t s = /* size in words */
+ ((size + sizeof(Object) - 1) / sizeof(Object)) + 1;
+--- a/lib/xwidgets/xaw/list.c 2011-06-18 07:41:13.000000000 -0300
++++ b/lib/xwidgets/xaw/list.c 2023-04-22 14:32:58.923738362 -0300
+@@ -2,14 +2,15 @@
+ #include <X11/Xaw/List.h>
+
+
+-static char **Get_List (Object x) {
++static const char **Get_List (Object x) {
+ register int i, n;
+- register char *s, **l;
++ register char *s;
++ register const char **l;
+ Alloca_Begin;
+
+ Check_List (x);
+ n = Fast_Length (x);
+- l = (char **)XtMalloc ((n+1) * sizeof (char *));
++ l = (const char **)XtMalloc ((n+1) * sizeof (char *));
+ for (i = 0; i < n; i++, x = Cdr (x)) {
+ Get_Strsym_Stack (Car (x), s);
+ l[i] = XtNewString (s);