summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAmy Liffey <amynka@gentoo.org>2017-03-21 09:16:23 +0100
committerAmy Liffey <amynka@gentoo.org>2017-03-21 09:35:11 +0100
commitbd6727aa850ed00d5c16c448a7a50114b55b86b1 (patch)
treea7d04bed8f7a83faa39e440ff8fc601e37e3be56 /dev-scheme/gambit/gambit-4.8.8.ebuild
parentdev-perl/Text-Template: Bump to version 1.470.0 (diff)
downloadgentoo-bd6727aa850ed00d5c16c448a7a50114b55b86b1.tar.gz
gentoo-bd6727aa850ed00d5c16c448a7a50114b55b86b1.tar.bz2
gentoo-bd6727aa850ed00d5c16c448a7a50114b55b86b1.zip
dev-scheme/gambit: version bump 4.8.8 bug #612088
Submitted-by: Bill Six <billsix@gmail.com> Package-Manager: portage-2.3.0
Diffstat (limited to 'dev-scheme/gambit/gambit-4.8.8.ebuild')
-rw-r--r--dev-scheme/gambit/gambit-4.8.8.ebuild57
1 files changed, 57 insertions, 0 deletions
diff --git a/dev-scheme/gambit/gambit-4.8.8.ebuild b/dev-scheme/gambit/gambit-4.8.8.ebuild
new file mode 100644
index 000000000000..999cda7fb2eb
--- /dev/null
+++ b/dev-scheme/gambit/gambit-4.8.8.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit eutils elisp-common
+
+MY_PV="${PV//./_}"
+MY_P="${PN}-v${MY_PV}"
+
+DESCRIPTION="Gambit-C is a native Scheme to C compiler and interpreter"
+HOMEPAGE="http://www.iro.umontreal.ca/~gambit/"
+SRC_URI="http://www-labs.iro.umontreal.ca/~gambit/download/gambit/v${PV%.*}/source/${MY_P}.tgz"
+
+LICENSE="|| ( Apache-2.0 LGPL-2.1 )"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64 ~x86 ~amd64-linux ~x86-linux ~x86-macos"
+
+DEPEND="emacs? ( virtual/emacs )"
+RDEPEND=""
+
+SITEFILE="50gambit-gentoo.el"
+
+S="${WORKDIR}/${MY_P}" #-devel
+
+IUSE="emacs static"
+
+src_configure() {
+ econf $(use_enable !static shared) \
+ --docdir="${EPREFIX}"/usr/share/doc/${PF} \
+ --enable-gnu-gcc-specific-options \
+ --enable-gnu-gcc-no-strict-aliasing \
+ --enable-single-host \
+ --disable-absolute-shared-libs \
+ --enable-type-checking
+}
+
+src_compile() {
+ emake bootstrap
+
+ if use emacs; then
+ elisp-compile misc/*.el || die
+ fi
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ keepdir /usr/share/"${MY_PN}"
+}
+
+pkg_postinst() {
+ use emacs && elisp-site-regen
+}
+
+pkg_postrm() {
+ use emacs && elisp-site-regen
+}