summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2022-05-17 22:41:32 +0200
committerMaciej Barć <xgqt@gentoo.org>2022-05-17 23:09:45 +0200
commit2b5ccfe9e3dfcce36fa9bf645bd93f7fee6d1828 (patch)
treeeb22a202ad8ff36b02d9570942a54eca6adcf452 /dev-scheme/guile-gi/guile-gi-0.3.1-r1.ebuild
parentapp-emulation/qemu: quote EROOT when passing it as an argument (diff)
downloadgentoo-2b5ccfe9e3dfcce36fa9bf645bd93f7fee6d1828.tar.gz
gentoo-2b5ccfe9e3dfcce36fa9bf645bd93f7fee6d1828.tar.bz2
gentoo-2b5ccfe9e3dfcce36fa9bf645bd93f7fee6d1828.zip
dev-scheme/guile-gi: drop useless static-libs USE flag
as QA requested https://projects.gentoo.org/qa/policy-guide/installed-files.html#pg0302 Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'dev-scheme/guile-gi/guile-gi-0.3.1-r1.ebuild')
-rw-r--r--dev-scheme/guile-gi/guile-gi-0.3.1-r1.ebuild57
1 files changed, 0 insertions, 57 deletions
diff --git a/dev-scheme/guile-gi/guile-gi-0.3.1-r1.ebuild b/dev-scheme/guile-gi/guile-gi-0.3.1-r1.ebuild
deleted file mode 100644
index cf870f83e265..000000000000
--- a/dev-scheme/guile-gi/guile-gi-0.3.1-r1.ebuild
+++ /dev/null
@@ -1,57 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit autotools
-
-DESCRIPTION="Bindings for GObject Introspection and libgirepository for Guile"
-HOMEPAGE="https://spk121.github.io/guile-gi/"
-
-if [[ "${PV}" == *9999* ]] ; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/spk121/${PN}.git"
-else
- SRC_URI="https://github.com/spk121/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~amd64"
-fi
-
-LICENSE="GPL-3"
-SLOT="0"
-IUSE="static-libs"
-RESTRICT="strip test" # Tests fail
-
-DEPEND="
- >=dev-scheme/guile-2.0.9:=
- dev-libs/gobject-introspection
- x11-libs/gtk+:3[introspection]
-"
-RDEPEND="${DEPEND}"
-BDEPEND="sys-apps/texinfo"
-
-# guile generates ELF files without use of C or machine code
-# It's a portage's false positive. bug #677600
-QA_PREBUILT='*[.]go'
-
-src_prepare() {
- default
-
- # http://debbugs.gnu.org/cgi/bugreport.cgi?bug=38112
- find "${S}" -name "*.scm" -exec touch {} + || die
-
- eautoreconf
-}
-
-src_configure() {
- econf --enable-introspection=yes $(use_enable static-libs static)
-}
-
-src_install() {
- default
-
- mv "${D}"/usr/share/doc/${PN} "${D}"/usr/share/doc/${PF} || die
-
- if ! use static-libs ; then
- find "${ED}" -type f -name '*.la' -delete || die
- fi
-}