summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2021-07-24 11:40:58 +0100
committerSergei Trofimovich <slyfox@gentoo.org>2021-07-24 11:40:58 +0100
commit8a424c8cbe741c499bf957b2d68e0f18f0e4d64e (patch)
tree89dff2e905f9952f10eabb342682069c60a42b89 /dev-scheme/guile-git
parentdev-haskell/xss-sanitize: update to EAPI=8 (diff)
downloadgentoo-8a424c8cbe741c499bf957b2d68e0f18f0e4d64e.tar.gz
gentoo-8a424c8cbe741c499bf957b2d68e0f18f0e4d64e.tar.bz2
gentoo-8a424c8cbe741c499bf957b2d68e0f18f0e4d64e.zip
dev-scheme/guile-git: bump up to 0.5.2
Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
Diffstat (limited to 'dev-scheme/guile-git')
-rw-r--r--dev-scheme/guile-git/Manifest1
-rw-r--r--dev-scheme/guile-git/guile-git-0.5.2.ebuild54
2 files changed, 55 insertions, 0 deletions
diff --git a/dev-scheme/guile-git/Manifest b/dev-scheme/guile-git/Manifest
index 2987d1221564..025f463e962e 100644
--- a/dev-scheme/guile-git/Manifest
+++ b/dev-scheme/guile-git/Manifest
@@ -1 +1,2 @@
DIST guile-git-0.5.1.tar.gz 305077 BLAKE2B f1dd4dade424045f992f9df9fb6c0c6e010deab26d77b32c6a7febda20e03192c91a5ec024bfdf05ea9585c7be307610c1eea6d569a5a97b90d5eedf715e5c59 SHA512 b5a07fc3e2a6c8d6277b3a2d6c2d47461e76441573dcf02c046e272853e3d46266adb2025e15f203d590b751def21c026eb55ed66a6f81795c1409ae5d6aa3c2
+DIST guile-git-0.5.2.tar.gz 305493 BLAKE2B 03fa85e1943fadc5e7e2da4bed2b6476e5a275856ed087a1730815defc17586f43eb2006bc3970d6f97d42822bcf83ef3d57a74c9a7ddb2fb877f5f0f8237a49 SHA512 4ac55c04c555f1a343f842bbda80d54314697d5bbc28bc3967edfdfacb8afa07c673ef7fd651388a6c55b6977b041174732cde14359a0127f0b931364a7eeda9
diff --git a/dev-scheme/guile-git/guile-git-0.5.2.ebuild b/dev-scheme/guile-git/guile-git-0.5.2.ebuild
new file mode 100644
index 000000000000..bd0165fade55
--- /dev/null
+++ b/dev-scheme/guile-git/guile-git-0.5.2.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# I extract those manually from https://gitlab.com/guile-git/guile-git/-/releases
+# from 'source tarball' link. Is there a better stable link?
+UPLOAD_PV=0.5.2
+UPLOAD_ID=6450f3991aa524484038cdcea3fb248d
+
+[[ $PV == ${UPLOAD_PV} ]] || die "${CATEGORY}/${P}: update 'UPLOAD_ID' to match ${PV}"
+
+DESCRIPTION="Guile bindings of git"
+HOMEPAGE="https://gitlab.com/guile-git/guile-git"
+SRC_URI="https://gitlab.com/guile-git/guile-git/uploads/${UPLOAD_ID}/guile-git-${PV}.tar.gz"
+
+LICENSE="LGPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+# Works without sandbox. But under sandbox sshd claims to break the protocol.
+RESTRICT=test
+
+# older libgit seems to be incompatible with guile-git bindings
+# https://github.com/trofi/nix-guix-gentoo/issues/7
+RDEPEND="
+ >=dev-scheme/guile-2.0.11:=
+ dev-scheme/bytestructures
+ >=dev-libs/libgit2-1:=
+"
+DEPEND="${RDEPEND}"
+
+# guile generates ELF files without use of C or machine code
+# It's a portage's false positive. bug #677600
+QA_FLAGS_IGNORED='.*[.]go'
+
+src_prepare() {
+ default
+
+ # guile is trying to avoid recompilation by checking if file
+ # /usr/lib64/guile/2.2/site-ccache/<foo>
+ # is newer than
+ # <foo>
+ # In case it is instead of using <foo> guile
+ # loads system one (from potentially older version of package).
+ # To work it around we bump last modification timestamp of
+ # '*.scm' files.
+ # http://debbugs.gnu.org/cgi/bugreport.cgi?bug=38112
+ find "${S}" -name "*.scm" -exec touch {} + || die
+}
+
+src_test() {
+ emake check VERBOSE=1
+}