summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2022-03-15 20:24:23 +0100
committerMaciej Barć <xgqt@gentoo.org>2022-03-15 20:25:06 +0100
commitda6351c2e7256e8cf151a98ba10cb4e904a84ffb (patch)
treeace142aedc9f96f3e88a13bfab33eb15cdc7bcea /dev-scheme/guile
parentapp-containers/docker-compose: drop 2.3.3 (diff)
downloadgentoo-da6351c2e7256e8cf151a98ba10cb4e904a84ffb.tar.gz
gentoo-da6351c2e7256e8cf151a98ba10cb4e904a84ffb.tar.bz2
gentoo-da6351c2e7256e8cf151a98ba10cb4e904a84ffb.zip
dev-scheme/guile: port 1.8 to EAPI 8
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'dev-scheme/guile')
-rw-r--r--dev-scheme/guile/files/guile-1.8.8-gtexinfo-5.patch4
-rw-r--r--dev-scheme/guile/guile-1.8.8-r4.ebuild (renamed from dev-scheme/guile/guile-1.8.8-r3.ebuild)110
2 files changed, 61 insertions, 53 deletions
diff --git a/dev-scheme/guile/files/guile-1.8.8-gtexinfo-5.patch b/dev-scheme/guile/files/guile-1.8.8-gtexinfo-5.patch
index d7fbda15c101..703e1fab9a48 100644
--- a/dev-scheme/guile/files/guile-1.8.8-gtexinfo-5.patch
+++ b/dev-scheme/guile/files/guile-1.8.8-gtexinfo-5.patch
@@ -2,8 +2,8 @@ $NetBSD: patch-doc_tutorial_guile-tut.texi,v 1.1 2013/11/30 07:06:25 dsainty Exp
Compatibility with gtexinfo 5.2
---- doc/tutorial/guile-tut.texi 2010-12-14 06:24:39.000000000 +1300
-+++ doc/tutorial/guile-tut.texi 2013-11-30 19:44:28.304575529 +1300
+--- a/doc/tutorial/guile-tut.texi 2010-12-14 06:24:39.000000000 +1300
++++ b/doc/tutorial/guile-tut.texi 2013-11-30 19:44:28.304575529 +1300
@@ -446,7 +446,7 @@
Schemer} from that list.}
diff --git a/dev-scheme/guile/guile-1.8.8-r3.ebuild b/dev-scheme/guile/guile-1.8.8-r4.ebuild
index bd9822080ac9..e4d5e582d1d9 100644
--- a/dev-scheme/guile/guile-1.8.8-r3.ebuild
+++ b/dev-scheme/guile/guile-1.8.8-r4.ebuild
@@ -1,56 +1,64 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
-inherit epatch autotools flag-o-matic elisp-common
+EAPI=8
-DESCRIPTION="Scheme interpreter"
+MAJOR="1.8"
+
+inherit autotools flag-o-matic elisp-common
+
+DESCRIPTION="GNU Ubiquitous Intelligent Language for Extensions"
HOMEPAGE="https://www.gnu.org/software/guile/"
SRC_URI="mirror://gnu/guile/${P}.tar.gz"
LICENSE="LGPL-2.1"
KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~m68k ~mips ppc ppc64 ~s390 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos"
IUSE="debug debug-freelist debug-malloc +deprecated discouraged emacs networking nls readline +regex +threads"
-
RESTRICT="!regex? ( test )"
+# Guile seems to contain some slotting support, /usr/share/guile/ is slotted,
+# but there are lots of collisions. Most in /usr/share/libguile. Therefore
+# I'm slotting this in the same slot as guile-1.6* for now.
+SLOT="12/8"
+
RDEPEND="
>=dev-libs/gmp-4.1:0=
dev-libs/libltdl:0=
sys-devel/gettext
sys-libs/ncurses:0=
virtual/libcrypt:=
- emacs? ( >=app-editors/emacs-23.1:* )
- readline? ( sys-libs/readline:0= )"
-DEPEND="${RDEPEND}
+ readline? ( sys-libs/readline:0= )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
sys-apps/texinfo
- sys-devel/libtool"
-
-# Guile seems to contain some slotting support, /usr/share/guile/ is slotted,
-# but there are lots of collisions. Most in /usr/share/libguile. Therefore
-# I'm slotting this in the same slot as guile-1.6* for now.
-SLOT="12/8"
-MAJOR="1.8"
+ sys-devel/libtool
+ emacs? ( >=app-editors/emacs-23.1:* )
+"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-fix_guile-config.patch
+ "${FILESDIR}"/${P}-gcc46.patch
+ "${FILESDIR}"/${P}-gcc5.patch
+ "${FILESDIR}"/${P}-makeinfo-5.patch
+ "${FILESDIR}"/${P}-gtexinfo-5.patch
+ "${FILESDIR}"/${P}-readline.patch
+ "${FILESDIR}"/${P}-tinfo.patch
+ "${FILESDIR}"/${P}-sandbox.patch
+ "${FILESDIR}"/${P}-mkdir-mask.patch
+ "${FILESDIR}"/${PN}-1.8.8-texinfo-6.7.patch
+)
+
+DOCS=( AUTHORS ChangeLog GUILE-VERSION HACKING NEWS README THANKS )
src_prepare() {
- epatch "${FILESDIR}/${P}-fix_guile-config.patch" \
- "${FILESDIR}/${P}-gcc46.patch" \
- "${FILESDIR}/${P}-gcc5.patch" \
- "${FILESDIR}/${P}-makeinfo-5.patch" \
- "${FILESDIR}/${P}-gtexinfo-5.patch" \
- "${FILESDIR}/${P}-readline.patch" \
- "${FILESDIR}/${P}-tinfo.patch" \
- "${FILESDIR}/${P}-sandbox.patch" \
- "${FILESDIR}/${P}-mkdir-mask.patch" \
- "${FILESDIR}/${PN}-1.8.8-texinfo-6.7.patch"
+ default
sed \
-e "s/AM_CONFIG_HEADER/AC_CONFIG_HEADERS/g" \
-e "/AM_PROG_CC_STDC/d" \
-i guile-readline/configure.in || die
- epatch_user
-
mv "${S}"/configure.{in,ac} || die
mv "${S}"/guile-readline/configure.{in,ac} || die
@@ -62,24 +70,25 @@ src_configure() {
filter-flags -ftree-vectorize
#will fail for me if posix is disabled or without modules -- hkBst
- econf \
- --disable-error-on-warning \
- --disable-static \
- --enable-posix \
- $(use_enable networking) \
- $(use_enable readline) \
- $(use_enable regex) \
- $(use deprecated || use_enable discouraged) \
- $(use_enable deprecated) \
- $(use_enable emacs elisp) \
- $(use_enable nls) \
- --disable-rpath \
- $(use_enable debug-freelist) \
- $(use_enable debug-malloc) \
- $(use_enable debug guile-debug) \
- $(use_with threads) \
- --with-modules \
- EMACS=no
+ myconf=(
+ --disable-error-on-warning
+ --disable-static
+ --enable-posix
+ $(use_enable networking)
+ $(use_enable readline)
+ $(use_enable regex)
+ $(use deprecated || use_enable discouraged)
+ $(use_enable deprecated)
+ $(use_enable emacs elisp)
+ $(use_enable nls)
+ --disable-rpath
+ $(use_enable debug-freelist)
+ $(use_enable debug-malloc)
+ $(use_enable debug guile-debug)
+ $(use_with threads)
+ --with-modules
+ )
+ econf "${myconf[@]}" EMACS=no
}
src_compile() {
@@ -94,20 +103,19 @@ src_compile() {
}
src_install() {
- emake DESTDIR="${D}" install
-
- dodoc AUTHORS ChangeLog GUILE-VERSION HACKING NEWS README THANKS
+ default
# texmacs needs this, closing bug #23493
dodir /etc/env.d
- echo "GUILE_LOAD_PATH=\"${EPREFIX}/usr/share/guile/${MAJOR}\"" > "${ED}"/etc/env.d/50guile || die
+ echo "GUILE_LOAD_PATH=\"${EPREFIX}/usr/share/guile/${MAJOR}\"" \
+ > "${ED}"/etc/env.d/50guile || die
# necessary for registering slib, see bug 206896
keepdir /usr/share/guile/site
if use emacs; then
- elisp-install ${PN} emacs/*.{el,elc} || die
- elisp-site-file-install "${FILESDIR}/50${PN}-gentoo.el" || die
+ elisp-install ${PN} emacs/*.{el,elc}
+ elisp-site-file-install "${FILESDIR}/50${PN}-gentoo.el"
fi
}