summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-scheme/racket/racket-6.0.1.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-scheme/racket/racket-6.0.1.ebuild')
-rw-r--r--dev-scheme/racket/racket-6.0.1.ebuild70
1 files changed, 70 insertions, 0 deletions
diff --git a/dev-scheme/racket/racket-6.0.1.ebuild b/dev-scheme/racket/racket-6.0.1.ebuild
new file mode 100644
index 000000000000..845364807c74
--- /dev/null
+++ b/dev-scheme/racket/racket-6.0.1.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+# for live ebuilds uncomment inherit git-2, comment SRC_URI and empty KEYWORDS
+
+inherit eutils pax-utils
+#inherit git-2
+
+DESCRIPTION="Racket is a general-purpose programming language with strong support for domain-specific languages"
+HOMEPAGE="http://racket-lang.org/"
+SRC_URI="minimal? ( http://download.racket-lang.org/installers/${PV}/${PN}-minimal-${PV}-src-builtpkgs.tgz ) !minimal? ( http://download.racket-lang.org/installers/${PV}/${P}-src-builtpkgs.tgz )"
+#SRC_URI="http://pre.racket-lang.org/installers/plt-${PV}-src-unix.tgz"
+EGIT_REPO_URI="git://git.racket-lang.org/plt.git"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="doc +futures +jit minimal +places +threads +X"
+REQUIRED_USE="futures? ( jit )"
+
+# see bug 426316: racket/draw (which depends on cairo) is sometimes used in compile-time code or when rendering documentation
+RDEPEND="dev-db/sqlite:3 x11-libs/cairo[X?] virtual/libffi"
+DEPEND="${RDEPEND}"
+
+EGIT_SOURCEDIR="${WORKDIR}/${P}"
+S="${WORKDIR}/${P}/src"
+
+src_prepare() {
+ #remove bundled libraries
+ rm -rf foreign/libffi/
+}
+
+src_configure() {
+# according to vapier, we should use the bundled libtool
+# such that we don't preclude cross-compile. Thus don't use
+# --enable-lt=/usr/bin/libtool
+ econf \
+ $(use_enable X gracket) \
+ $(use_enable doc docs) \
+ --enable-shared \
+ $(use_enable jit) \
+ --enable-foreign \
+ $(use_enable places) \
+ $(use_enable futures) \
+ $(use_enable threads pthread)
+}
+
+src_compile() {
+ if use jit; then
+ pushd racket
+ emake cgc
+ pax-mark m .libs/racketcgc
+ emake 3m
+ pax-mark m .libs/racket3m
+ popd
+ fi
+ emake
+}
+
+src_install() {
+ #racket now comes with desktop files, but DESTDIR is mishandled
+ for f in /usr/share/applications/{drracket,slideshow}.desktop; do
+ sed -ie "s|${D}||" "${D}/${f}"
+ done
+
+ emake DESTDIR="${D}" install
+}