summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAmy Liffey <amynka@gentoo.org>2019-04-28 19:09:48 +0200
committerAmy Liffey <amynka@gentoo.org>2019-04-28 20:24:18 +0200
commit2a08fd6ac900010fa248c1a30b88e73fda1ec655 (patch)
tree7c2a6a10288c986187cecec977333331390e6931 /dev-scheme/racket/racket-7.2.ebuild
parentsys-auth/libfprint: Do not build docs at all (diff)
downloadgentoo-2a08fd6ac900010fa248c1a30b88e73fda1ec655.tar.gz
gentoo-2a08fd6ac900010fa248c1a30b88e73fda1ec655.tar.bz2
gentoo-2a08fd6ac900010fa248c1a30b88e73fda1ec655.zip
dev-scheme/racket: version bump 7.2
Signed-off-by: Amy Liffey <amynka@gentoo.org> Package-Manager: Portage-2.3.62, Repoman-2.3.11
Diffstat (limited to 'dev-scheme/racket/racket-7.2.ebuild')
-rw-r--r--dev-scheme/racket/racket-7.2.ebuild95
1 files changed, 95 insertions, 0 deletions
diff --git a/dev-scheme/racket/racket-7.2.ebuild b/dev-scheme/racket/racket-7.2.ebuild
new file mode 100644
index 000000000000..6c313c38b06b
--- /dev/null
+++ b/dev-scheme/racket/racket-7.2.ebuild
@@ -0,0 +1,95 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit pax-utils
+
+DESCRIPTION="General purpose, multi-paradigm Lisp-Scheme programming language"
+HOMEPAGE="https://racket-lang.org/"
+SRC_URI="minimal? ( https://download.racket-lang.org/installers/${PV}/${PN}-minimal-${PV}-src-builtpkgs.tgz ) !minimal? ( https://download.racket-lang.org/installers/${PV}/${P}-src-builtpkgs.tgz )"
+LICENSE="GPL-3+ LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86"
+IUSE="doc +futures +jit minimal +places +readline +threads +X"
+REQUIRED_USE="futures? ( jit )"
+
+RDEPEND="dev-db/sqlite:3
+ media-libs/libpng:0
+ x11-libs/cairo[X?]
+ x11-libs/pango[X?]
+ virtual/libffi
+ virtual/jpeg:0
+ readline? ( dev-libs/libedit )
+ X? ( x11-libs/gtk+[X?] )"
+RDEPEND="${RDEPEND} !dev-tex/slatex"
+
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/${P}/src"
+
+src_prepare() {
+ default
+ rm -r foreign/libffi || die 'failed to remove bundled libffi'
+}
+
+src_configure() {
+ # According to vapier, we should use the bundled libtool
+ # such that we don't preclude cross-compile. Thus don't use
+ # --enable-lt=/usr/bin/libtool
+ econf \
+ --docdir="${EPREFIX}"/usr/share/doc/${PF} \
+ --enable-shared \
+ --enable-float \
+ --enable-libffi \
+ --enable-foreign \
+ --disable-libs \
+ --disable-strip \
+ $(use_enable X gracket) \
+ $(use_enable doc docs) \
+ $(use_enable jit) \
+ $(use_enable places) \
+ $(use_enable futures) \
+ $(use_enable threads pthread)
+}
+
+src_compile() {
+ if use jit; then
+ # When the JIT is enabled, a few binaries need to be pax-marked
+ # on hardened systems (bug 613634). The trick is to pax-mark
+ # them before they're used later in the build system. The
+ # following order for racketcgc and racket3m was determined by
+ # digging through the Makefile in src/racket to find out which
+ # targets would build those binaries but not use them.
+ pushd racket
+ emake cgc-core
+ pax-mark m .libs/racketcgc
+ pushd gc2
+ emake all
+ popd
+ pax-mark m .libs/racket3m
+ popd
+ fi
+
+ default
+}
+
+src_install() {
+ default
+
+ if use jit; then
+ # The final binaries need to be pax-marked, too, if you want to
+ # actually use them. The src_compile marking get lost somewhere
+ # in the install process.
+ for f in mred mzscheme racket; do
+ pax-mark m "${D}/usr/bin/${f}"
+ done
+
+ use X && pax-mark m "${D}/usr/$(get_libdir)/racket/gracket"
+ fi
+ # raco needs decompressed files for packages doc installation bug 662424
+ if use doc; then
+ docompress -x /usr/share/doc/${PF}
+ fi
+ find "${ED}" \( -name "*.a" -o -name "*.la" \) -delete || die
+}