summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2023-05-16 13:43:57 +0200
committerMaciej Barć <xgqt@gentoo.org>2023-05-16 13:50:43 +0200
commit30fe460e5275811feac4ac68c024c1e4ba1cae54 (patch)
treec236a1b1e46834d0a729fe46451a177cf832795c /dev-scheme
parentdev-scheme/guile-zstd: do not strip guile bytecode (diff)
downloadgentoo-30fe460e5275811feac4ac68c024c1e4ba1cae54.tar.gz
gentoo-30fe460e5275811feac4ac68c024c1e4ba1cae54.tar.bz2
gentoo-30fe460e5275811feac4ac68c024c1e4ba1cae54.zip
dev-scheme/guile-zlib: do not strip guile bytecode
Bug: https://bugs.gentoo.org/905898 Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'dev-scheme')
-rw-r--r--dev-scheme/guile-zlib/guile-zlib-0.1.0-r1.ebuild (renamed from dev-scheme/guile-zlib/guile-zlib-0.1.0.ebuild)10
1 files changed, 9 insertions, 1 deletions
diff --git a/dev-scheme/guile-zlib/guile-zlib-0.1.0.ebuild b/dev-scheme/guile-zlib/guile-zlib-0.1.0-r1.ebuild
index fb293dfdba44..46d194b84e7f 100644
--- a/dev-scheme/guile-zlib/guile-zlib-0.1.0.ebuild
+++ b/dev-scheme/guile-zlib/guile-zlib-0.1.0-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -41,3 +41,11 @@ src_configure() {
# We need /${libdir} with shared library here.
econf LIBZ_LIBDIR="${EPREFIX}/$(get_libdir)"
}
+
+src_install() {
+ default
+
+ # Workaround llvm-strip problem of mangling guile ELF debug
+ # sections: https://bugs.gentoo.org/905898
+ dostrip -x "/usr/$(get_libdir)/guile"
+}