summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2022-02-10 00:15:44 +0100
committerMaciej Barć <xgqt@gentoo.org>2022-02-10 00:16:38 +0100
commit901b921d513b094f03aa99b22026ca26c7a05407 (patch)
tree374049c9ca7154a78df487e6b1ab9fbde3df2d0d /dev-scheme
parentmedia-video/pipewire: remove unused patch (diff)
downloadgentoo-901b921d513b094f03aa99b22026ca26c7a05407.tar.gz
gentoo-901b921d513b094f03aa99b22026ca26c7a05407.tar.bz2
gentoo-901b921d513b094f03aa99b22026ca26c7a05407.zip
dev-scheme/racket: bump to 8.4
Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'dev-scheme')
-rw-r--r--dev-scheme/racket/Manifest2
-rw-r--r--dev-scheme/racket/racket-8.4.ebuild162
2 files changed, 164 insertions, 0 deletions
diff --git a/dev-scheme/racket/Manifest b/dev-scheme/racket/Manifest
index faf44781e93f..6d163a423dc0 100644
--- a/dev-scheme/racket/Manifest
+++ b/dev-scheme/racket/Manifest
@@ -1,4 +1,6 @@
DIST racket-8.2-src-builtpkgs.tgz 150467561 BLAKE2B 5005aa852b089becd9d6da136a55a035ac5fd86bd1ad186ec30cdcf411927d444e1814797d63dbde3eb7b52bba7756e0464edf1d854d2ee7f5851caaae18ba55 SHA512 9e4c0cabfcbdb8c8742e8170548bee58021697e8b0842f575f94193db31adc04a7b9023ed8fd70dae197e5ec6f1aee7985d849be3ce5b4279f216e900ee143c7
DIST racket-8.3-src-builtpkgs.tgz 150608486 BLAKE2B f002934c07afab4152ad8395c4ab5c6c87ef810f5cf79cf5ae0b41f4caa4508e0044f4246812513def14130d507af57aa61efaff8106eaeac0b86918bd775902 SHA512 7c340f65d221343beb2b4205cdc58648bd65dceabdb16f40cda425474faa905f4dd441193dc6cd4856f7863fb83834721394d6888027db356f830eceb127dbae
+DIST racket-8.4-src-builtpkgs.tgz 151809822 BLAKE2B c42f7943975a6f91a03ef0f668d218571dfc4159eac5a5722b9513b978413a9617b4e1bf3ccabef051014311ecf51fdc80d7563942e9e645c442ddfc4995a308 SHA512 afd9f357673a28ac5e4529ea0879a4edc3dbffc5b8627aa3553f1caf867be3296b94620dc2d86b8bb3f0c7ec7743d0057ce897c5caa705e02f2cc469ce4c7116
DIST racket-minimal-8.2-src-builtpkgs.tgz 21187959 BLAKE2B 0f62a900e71ee101fa3acf0985b0a72215ac657285c5ce9e4f5f49189180b82dcca94ded9778b7ba92a42919f17b1dc24eec07e13c64c77e47fc958614d7dc0a SHA512 04950703fa73cdbbb10c234d57c89e70db6076b42d4a74ddb8cace9e0438b9a1431f7317baf31d667368ad75ae19e4eecec39667ba0c5b08a3580f8cc81f4f5e
DIST racket-minimal-8.3-src-builtpkgs.tgz 21212037 BLAKE2B 76a742efe7ba2c44eb935d4852c20be355ccff9b935b39226ef1935184b0a9179ef6ca2ac0a64f3c7a6ae4a0082117a12c668d7804a0b73b9f1a391eaba61994 SHA512 3cab4a24cab5c1ac107c8aead2ada6fa3ec7d7aa122716c78af584f055dadf89497168e95b36d99115ecd1a1905dc1ec51774dd2c8099198ec7d6aa9d380039d
+DIST racket-minimal-8.4-src-builtpkgs.tgz 21279666 BLAKE2B 25d5eb405cedaa9cadfa776c4dd66b87f1641c86b638110f1a3a788465aaf573f5f8054e1e6913e6c0123840a1a2f64d5855db5f52acace3475b91d095272a76 SHA512 92433c08508cfb1bdb9093e5c7c726630826e9046de02fcb3d402f3dd76aa98fc2d9a5d09515d44e7a50eab0e38d963d2202f48a44741c3cf7fe8e47d9404e63
diff --git a/dev-scheme/racket/racket-8.4.ebuild b/dev-scheme/racket/racket-8.4.ebuild
new file mode 100644
index 000000000000..ba7263a23ea8
--- /dev/null
+++ b/dev-scheme/racket/racket-8.4.ebuild
@@ -0,0 +1,162 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit desktop optfeature readme.gentoo-r1
+
+DESCRIPTION="General purpose, multi-paradigm Lisp-Scheme programming language"
+HOMEPAGE="https://racket-lang.org/"
+SRC_URI="
+ minimal? ( https://download.racket-lang.org/installers/${PV}/${PN}-minimal-${PV}-src-builtpkgs.tgz )
+ !minimal? ( https://download.racket-lang.org/installers/${PV}/${P}-src-builtpkgs.tgz )
+"
+S="${WORKDIR}/${P}/src"
+
+# See https://blog.racket-lang.org/2019/11/completing-racket-s-relicensing-effort.html
+LICENSE="
+ || ( MIT Apache-2.0 )
+ chez? ( Apache-2.0 )
+ !chez? ( LGPL-3 )
+"
+# Bytecode generated by Racket is not compatible between versions.
+# The bytecode version should be denoted by SLOT, in most cases
+# PV == SLOT but this has to be checked carefully and in cases
+# where we use _p, _pre, etc it will have to be set manually.
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86"
+IUSE="+chez +doc +futures +jit minimal +places +threads"
+# See bug #809785 re chez/threads
+REQUIRED_USE="chez? ( futures places ) futures? ( jit threads ) places? ( threads )"
+
+DEPEND="
+ !dev-tex/slatex
+ dev-db/sqlite:3
+ dev-libs/libffi:=
+"
+RDEPEND="${DEPEND}"
+
+# "mred" and "mzscheme" are binaries generated by Racket, not CC
+QA_FLAGS_IGNORED="usr/bin/mred usr/bin/mzscheme"
+
+DOC_CONTENTS="
+If you wish to use sys-libs/readline instead of dev-libs/libedit
+for readline-like features in the Racket's REPL you can install
+the package 'readline-gpl' using raco, Racket's package manager
+https://pkgs.racket-lang.org/package/readline-gpl
+"
+
+# Package database files (for pkg_preinst & pkg_config)
+PKGDB=(
+ /usr/share/racket/info-cache.rktd
+ /usr/share/racket/links.rktd
+ /usr/share/racket/pkgs/pkgs.rktd
+)
+
+src_prepare() {
+ # Prepare the environment
+ unset PLTADDONDIR PLTCOLLECTS PLTCONFIGDIR PLTUSERHOME
+
+ default
+
+ # Remove bundled libffi
+ rm -r ./bc/foreign/libffi || die "failed to remove bundled libffi"
+}
+
+src_configure() {
+ # Libtool:
+ # According to vapier, we should use the bundled libtool
+ # such that we don't preclude cross-compile.
+ # Thus don't use --enable-lt=/usr/bin/libtool
+ # Backend:
+ # --enable-bc builds Racket w/o chez backend
+ # C Libraries:
+ # --enable-libs & --disable-shared is the way to build
+ # .a files that are needed to embed Racket into programs
+ # https://docs.racket-lang.org/inside/cs-embedding.html
+ local myconf=(
+ --disable-shared
+ --disable-strip
+ --docdir="${EPREFIX}/usr/share/doc/${PF}"
+ --enable-libs
+ $(usex chez "--enable-cs --enable-csonly" "--enable-bc --enable-bconly")
+ $(use_enable doc docs)
+ )
+ # Some options are togglable only for the BC version (are forced in CS)
+ ! use chez && myconf+=(
+ --enable-float
+ --enable-foreign
+ --enable-gracket
+ --enable-libffi
+ $(use_enable futures)
+ $(use_enable jit)
+ $(use_enable places)
+ $(use_enable threads pthread)
+ )
+ econf "${myconf[@]}"
+}
+
+src_install() {
+ default
+
+ # Install Racket boot files
+ use chez && emake -C "${S}"/cs/c DESTDIR="${ED}" unix-install-boot-files
+
+ # raco needs decompressed files for packages doc installation bug 662424
+ use doc && docompress -x /usr/share/doc/${PF}
+
+ # Create missing desktop files and icon
+ if ! use minimal ; then
+ newicon "${ED}/usr/share/racket/drracket-exe-icon.png" "racket.png"
+ make_desktop_entry "gracket" "GRacket" "racket" "Development;Education;"
+ make_desktop_entry "plt-games" "PLT Games" "racket" "Education;Game;"
+ fi
+
+ readme.gentoo_create_doc
+}
+
+pkg_preinst() {
+ # If we are merging the same SLOT check if package
+ # database files exist and do not overwrite them
+ if has_version "${CATEGORY}/${PN}:${SLOT}" ; then
+ echo "We are installing the same SLOT: ${SLOT}"
+ local rktd
+ for rktd in "${PKGDB[@]}" ; do
+ if [[ -f "${EROOT}"/${rktd} ]] && [[ -f "${ED}"/${rktd} ]] ; then
+ einfo "Keeping old file: ${rktd}"
+ mv "${ED}"/${rktd} "${ED}"/${rktd}.bak ||
+ die "failed to create a backup of ${rktd}"
+ cp "${EROOT}"/${rktd} "${ED}"/${rktd} ||
+ die "failed to create a copy of ${rktd}"
+ fi
+ done
+ fi
+}
+
+pkg_postinst() {
+ # If we have any pkgs not included in Racket main distribution (outsiders),
+ # then we have to re-setup them or during installation other pkgs will want
+ # to recompile parts of "outsider" pkgs they depend upon (and fail).
+ local outsiders=( $(raco pkg show -i | grep 'link' | sed 's|link.*||g') )
+ if [[ -n "${outsiders[@]}" ]] ; then
+ ebegin "Running \"raco setup\" for outsider packages"
+ echo "Outsiders: ${outsiders[@]}"
+ raco setup --all-users --force --no-docs --no-user --pkgs "${outsiders[@]}"
+ eend 0 # do not fail
+ fi
+
+ optfeature "readline editing features in REPL" dev-libs/libedit
+ optfeature "generating PDF files using Scribble" dev-texlive/texlive-fontsextra
+
+ readme.gentoo_print_elog
+}
+
+pkg_config() {
+ einfo "Swapping package database backup files"
+
+ for rktd in "${PKGDB[@]}" ; do
+ mv "${EROOT}"/${rktd} "${EROOT}"/${rktd}.pkg_config
+ mv "${EROOT}"/${rktd}.bak "${EROOT}"/${rktd}
+ mv "${EROOT}"/${rktd}.pkg_config "${EROOT}"/${rktd}.bak
+ done
+}