summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2024-02-28 21:29:26 +0100
committerMaciej Barć <xgqt@gentoo.org>2024-02-28 22:21:21 +0100
commit964f79950bc01433d5795bb51668265ee77c296a (patch)
treeb72435abc21028e3f1b5b821ec09d3b1f5f20abe /dev-scheme
parentdev-scheme/guile-zlib: add missing pkgconfig dependencies (diff)
downloadgentoo-964f79950bc01433d5795bb51668265ee77c296a.tar.gz
gentoo-964f79950bc01433d5795bb51668265ee77c296a.tar.bz2
gentoo-964f79950bc01433d5795bb51668265ee77c296a.zip
dev-scheme/guile-gcrypt: add missing pkgconfig dependencies
as also declared inside this pkg guix.scm Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'dev-scheme')
-rw-r--r--dev-scheme/guile-gcrypt/guile-gcrypt-0.4.0-r1.ebuild (renamed from dev-scheme/guile-gcrypt/guile-gcrypt-0.4.0.ebuild)28
1 files changed, 20 insertions, 8 deletions
diff --git a/dev-scheme/guile-gcrypt/guile-gcrypt-0.4.0.ebuild b/dev-scheme/guile-gcrypt/guile-gcrypt-0.4.0-r1.ebuild
index 925cd6308503..e435603ff2d5 100644
--- a/dev-scheme/guile-gcrypt/guile-gcrypt-0.4.0.ebuild
+++ b/dev-scheme/guile-gcrypt/guile-gcrypt-0.4.0-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -7,18 +7,32 @@ inherit autotools
DESCRIPTION="Guile bindings of libgcrypt"
HOMEPAGE="https://notabug.org/cwebber/guile-gcrypt"
-SRC_URI="https://notabug.org/cwebber/guile-gcrypt/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-S="${WORKDIR}/${PN}"
+
+if [[ "${PV}" == *9999* ]] ; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://notabug.org/cwebber/${PN}.git"
+else
+ SRC_URI="https://notabug.org/cwebber/guile-gcrypt/archive/v${PV}.tar.gz
+ -> ${P}.tar.gz"
+ S="${WORKDIR}/${PN}"
+
+ KEYWORDS="~amd64 ~x86"
+fi
LICENSE="GPL-3"
SLOT="0"
-KEYWORDS="~amd64 ~x86"
RDEPEND="
>=dev-scheme/guile-2.0.11:=
dev-libs/libgcrypt:0=
"
-DEPEND="${RDEPEND}"
+DEPEND="
+ ${RDEPEND}
+"
+BDEPEND="
+ virtual/pkgconfig
+"
# guile generates ELF files without use of C or machine code
# It's a portage's false positive. bug #677600
@@ -26,12 +40,10 @@ QA_PREBUILT='*[.]go'
src_prepare() {
default
+ eautoreconf
# http://debbugs.gnu.org/cgi/bugreport.cgi?bug=38112
find "${S}" -name "*.scm" -exec touch {} + || die
-
- # upstream tag on top of source tree. has no autogenerated files
- eautoreconf
}
src_install() {