summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAkinori Hattori <hattya@gentoo.org>2024-01-17 20:56:15 +0900
committerAkinori Hattori <hattya@gentoo.org>2024-01-17 20:56:15 +0900
commitad4408b7e41fd10ef76f08481287e5438ae5389c (patch)
tree832463a6e89cde0411a4f321ae5152729cd9c05c /dev-scheme
parentdev-qt/qtwebengine: Restore accidentally dropped patch (diff)
downloadgentoo-ad4408b7e41fd10ef76f08481287e5438ae5389c.tar.gz
gentoo-ad4408b7e41fd10ef76f08481287e5438ae5389c.tar.bz2
gentoo-ad4408b7e41fd10ef76f08481287e5438ae5389c.zip
dev-scheme/stklos: respect LDFLAGS
Closes: https://bugs.gentoo.org/920928 Signed-off-by: Akinori Hattori <hattya@gentoo.org>
Diffstat (limited to 'dev-scheme')
-rw-r--r--dev-scheme/stklos/files/stklos-2.00-ldflags.patch15
-rw-r--r--dev-scheme/stklos/stklos-2.00-r1.ebuild61
2 files changed, 76 insertions, 0 deletions
diff --git a/dev-scheme/stklos/files/stklos-2.00-ldflags.patch b/dev-scheme/stklos/files/stklos-2.00-ldflags.patch
new file mode 100644
index 000000000000..9e695718e6b0
--- /dev/null
+++ b/dev-scheme/stklos/files/stklos-2.00-ldflags.patch
@@ -0,0 +1,15 @@
+--- a/lib/Makefile.am
++++ b/lib/Makefile.am
+@@ -195,12 +195,6 @@
+ lib/streams: lib
+ lib/srfi: lib/scheme lib/stklos lib/streams
+
+-readline-complete.@SH_SUFFIX@: readline-complete.c
+- @CC@ @CFLAGS@ @STKCFLAGS@ @SH_COMP_FLAGS@ -I../src @GCINC@ \
+- -c -o $*.o $*.c
+- @SH_LOADER@ @SH_LOAD_FLAGS@ -o $*.@SH_SUFFIX@ $*.o @DLLIBS@ @RDLINE@
+- /bin/rm -f $*.o
+-
+ #
+ # SRFIs support
+ #
diff --git a/dev-scheme/stklos/stklos-2.00-r1.ebuild b/dev-scheme/stklos/stklos-2.00-r1.ebuild
new file mode 100644
index 000000000000..99bdac6e81f2
--- /dev/null
+++ b/dev-scheme/stklos/stklos-2.00-r1.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+
+inherit autotools toolchain-funcs
+
+DESCRIPTION="Fast and light Scheme implementation"
+HOMEPAGE="https://stklos.net/"
+SRC_URI="https://${PN}.net/download/${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="threads"
+
+RDEPEND="dev-libs/boehm-gc[threads?]
+ dev-libs/gmp:=
+ dev-libs/libffi:=
+ dev-libs/libpcre2:="
+DEPEND="${RDEPEND}"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-gentoo.patch
+ "${FILESDIR}"/${P}-ldflags.patch
+)
+DOCS=( AUTHORS ChangeLog NEWS.md PACKAGES-USED {PORTING-NOTES,README}.md SUPPORTED-SRFIS )
+
+src_prepare() {
+ default
+
+ if ! use threads; then
+ sed -i '/threads.adoc/d' doc/refman/${PN}.adoc
+ rm -f tests/srfis/2{16,30}.stk
+ fi
+ eautoreconf
+ export LD="$(tc-getCC)"
+ export STKLOS_CONFDIR="${T}"/.config/${PN}
+}
+
+src_configure() {
+ econf \
+ --enable-threads=$(usex threads pthreads none) \
+ --without-provided-bignum \
+ --without-provided-ffi \
+ --without-provided-gc \
+ --without-provided-regexp
+}
+
+src_compile() {
+ emake
+}
+
+src_test() {
+ emake -j1 check
+}
+
+src_install() {
+ default
+ einstalldocs
+}