summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEli Schwartz <eschwartz93@gmail.com>2024-03-17 01:06:46 -0400
committerSam James <sam@gentoo.org>2024-03-17 05:28:44 +0000
commitd9ca5c919dd2bd59629a96056bc1884b1a52cdd5 (patch)
tree56781c177a4d36008665f7cb669c928f49b1e379 /dev-scheme
parentwww-servers/gatling: drop old (diff)
downloadgentoo-d9ca5c919dd2bd59629a96056bc1884b1a52cdd5.tar.gz
gentoo-d9ca5c919dd2bd59629a96056bc1884b1a52cdd5.tar.bz2
gentoo-d9ca5c919dd2bd59629a96056bc1884b1a52cdd5.zip
dev-scheme/bigloo: mark as LTO-unsafe
Still cannot actually compile it because of a raft of other bugs. My theory is that fixing this one issue makes the other issues easier to spot, at least, in addition to clearing up the LTO tracker bug. Closes: https://bugs.gentoo.org/858248 Signed-off-by: Eli Schwartz <eschwartz93@gmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-scheme')
-rw-r--r--dev-scheme/bigloo/bigloo-4.4c_p4-r6.ebuild13
1 files changed, 12 insertions, 1 deletions
diff --git a/dev-scheme/bigloo/bigloo-4.4c_p4-r6.ebuild b/dev-scheme/bigloo/bigloo-4.4c_p4-r6.ebuild
index dee6dc5c4eeb..4fff4bfd6313 100644
--- a/dev-scheme/bigloo/bigloo-4.4c_p4-r6.ebuild
+++ b/dev-scheme/bigloo/bigloo-4.4c_p4-r6.ebuild
@@ -3,7 +3,7 @@
EAPI=8
-inherit elisp-common toolchain-funcs
+inherit elisp-common flag-o-matic toolchain-funcs
MY_PV=${PV/_p/-} # e.g.: 4.4c_p4 -> 4.4c-4
MY_P="${PN}-${MY_PV}"
@@ -71,6 +71,17 @@ src_prepare() {
}
src_configure() {
+ # -Werror=lto-type-mismatch
+ # https://bugs.gentoo.org/858248
+ #
+ # The code has various issues that make it look quite worrying to enable
+ # LTO, so I wouldn't risk it even if upstream fixes this one. Cannot even
+ # test compile the package due to bug #870481, bug #911667
+ #
+ # It is also impossible to test from git if any of these are fixed, since
+ # you need a working version in order to compile from git.
+ filter-lto
+
tc-export AR AS CC CPP CXX LD
export CFLAGS
export LDFLAGS