summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2024-02-28 21:53:14 +0100
committerMaciej Barć <xgqt@gentoo.org>2024-02-28 22:24:12 +0100
commitf129b754cc1545f29bfeca95272ca78307216987 (patch)
treeeeecfb63f12f8cd49b55b9ee1d810b29d80b8450 /dev-scheme
parentdev-scheme/guile-ssh: drop old 0.16.3 (diff)
downloadgentoo-f129b754cc1545f29bfeca95272ca78307216987.tar.gz
gentoo-f129b754cc1545f29bfeca95272ca78307216987.tar.bz2
gentoo-f129b754cc1545f29bfeca95272ca78307216987.zip
dev-scheme/guile-ssh: add missing pkgconfig dependencies
as also declared inside this pkg guix.scm Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'dev-scheme')
-rw-r--r--dev-scheme/guile-ssh/guile-ssh-0.16.4-r1.ebuild (renamed from dev-scheme/guile-ssh/guile-ssh-0.16.4.ebuild)28
1 files changed, 20 insertions, 8 deletions
diff --git a/dev-scheme/guile-ssh/guile-ssh-0.16.4.ebuild b/dev-scheme/guile-ssh/guile-ssh-0.16.4-r1.ebuild
index bda391d671fb..5a331431ce4e 100644
--- a/dev-scheme/guile-ssh/guile-ssh-0.16.4.ebuild
+++ b/dev-scheme/guile-ssh/guile-ssh-0.16.4-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -8,22 +8,35 @@ inherit autotools
DESCRIPTION="Library providing access to the SSH protocol for GNU Guile"
HOMEPAGE="https://memory-heap.org/~avp/projects/guile-ssh/
https://github.com/artyom-poptsov/guile-ssh/"
-SRC_URI="https://github.com/artyom-poptsov/${PN}/archive/v${PV}.tar.gz
- -> ${P}.tar.gz"
+
+if [[ "${PV}" == *9999* ]] ; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://github.com/artyom-poptsov/${PN}.git"
+else
+ SRC_URI="https://github.com/artyom-poptsov/${PN}/archive/v${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+ KEYWORDS="~amd64 ~x86"
+fi
LICENSE="GPL-3+"
SLOT="0"
-KEYWORDS="~amd64 ~x86"
RDEPEND="
>=dev-scheme/guile-2.0.0:=
net-libs/libssh:0=[server,sftp]
"
-DEPEND="${RDEPEND}"
+DEPEND="
+ ${RDEPEND}
+"
+BDEPEND="
+ virtual/pkgconfig
+"
DOCS=( AUTHORS ChangeLog NEWS README THANKS TODO )
PATCHES=(
- "${FILESDIR}"/${PN}-0.16.2-tests.patch
+ "${FILESDIR}/${PN}-0.16.2-tests.patch"
)
# guile generates ELF files without use of C or machine code
@@ -32,11 +45,10 @@ QA_PREBUILT='*[.]go'
src_prepare() {
default
+ eautoreconf
# http://debbugs.gnu.org/cgi/bugreport.cgi?bug=38112
find "${S}" -name "*.scm" -exec touch {} + || die
-
- eautoreconf
}
src_install() {