summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTupone Alfredo <tupone@gentoo.org>2018-10-09 08:29:49 +0200
committerTupone Alfredo <tupone@gentoo.org>2018-10-09 08:29:49 +0200
commit24ce157947b89217937d883202a924b215fc7a68 (patch)
tree9ff6e0b16c4a6c1102660ad472b4b3497e13f66d /dev-tcltk/expect-lite/expect-lite-4.9.0.ebuild
parentdev-lang/gnat-gpl: Align patch with sys-devel/gcc (diff)
downloadgentoo-24ce157947b89217937d883202a924b215fc7a68.tar.gz
gentoo-24ce157947b89217937d883202a924b215fc7a68.tar.bz2
gentoo-24ce157947b89217937d883202a924b215fc7a68.zip
dev-tcltk/expect-lite: Version bump to 4.9.0
Signed-off-by: Alfredo Tupone <tupone@gentoo.org> Package-Manager: Portage-2.3.49, Repoman-2.3.11
Diffstat (limited to 'dev-tcltk/expect-lite/expect-lite-4.9.0.ebuild')
-rw-r--r--dev-tcltk/expect-lite/expect-lite-4.9.0.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/dev-tcltk/expect-lite/expect-lite-4.9.0.ebuild b/dev-tcltk/expect-lite/expect-lite-4.9.0.ebuild
new file mode 100644
index 000000000000..4ca05009dc47
--- /dev/null
+++ b/dev-tcltk/expect-lite/expect-lite-4.9.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+DESCRIPTION="quick and easy command line automation tool built on top of expect"
+HOMEPAGE="http://expect-lite.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${PN}_${PV}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug examples"
+
+RDEPEND="dev-tcltk/expect
+ debug? ( dev-tcltk/tclx )"
+
+S=${WORKDIR}/${PN}.proj
+
+DOCS=(
+ bashrc ChangeLog README
+)
+
+HTML_DOCS=(
+ "Docs/*"
+)
+
+src_install() {
+ default
+ dobin ${PN}
+ doman man/*
+
+ if use examples ; then
+ docinto examples
+ dodoc examples/*
+ fi
+}