summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-tcltk/iwidgets/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-tcltk/iwidgets/files')
-rw-r--r--dev-tcltk/iwidgets/files/4.0.1-path.patch63
1 files changed, 63 insertions, 0 deletions
diff --git a/dev-tcltk/iwidgets/files/4.0.1-path.patch b/dev-tcltk/iwidgets/files/4.0.1-path.patch
new file mode 100644
index 000000000000..095d9ed81e1c
--- /dev/null
+++ b/dev-tcltk/iwidgets/files/4.0.1-path.patch
@@ -0,0 +1,63 @@
+--- iwidgets4.0.1/Makefile.in
++++ iwidgets4.0.1/Makefile.in
+@@ -30,6 +30,7 @@
+
+ srcdir = @srcdir@
+ bindir = @bindir@
++mandir = @mandir@
+
+ # The following definition can be set to non-null for special systems
+ # like AFS with replication. It allows the pathnames used for installation
+@@ -48,7 +49,9 @@
+ BIN_INSTALL_DIR = $(INSTALL_ROOT)$(exec_prefix)/bin
+
+ # Top-level directory in which to install manual entries:
+-MAN_INSTALL_DIR = $(INSTALL_ROOT)$(prefix)/man/mann
++MAN_INSTALL_DIR = $(INSTALL_ROOT)$(mandir)/mann
++
++DATA_DIR = $(INSTALL_ROOT)$(prefix)/share/iwidgets$(IWIDGETS_VERSION)
+
+ # Directory containing Tcl source code (for library used during test):
+ TCL_SRC_DIR = @TCL_SRC_DIR@
+@@ -135,26 +138,26 @@
+ done;
+
+ install-demos:
+- @$(MKINSTALLDIRS) $(SCRIPT_INSTALL_DIR)/demos/images $(SCRIPT_INSTALL_DIR)/demos/html
+- @echo "Installing demos from $(srcdir)/demos into $(SCRIPT_INSTALL_DIR)/demos"
++ @$(MKINSTALLDIRS) $(DATA_DIR)/demos/images $(DATA_DIR)/demos/html
++ @echo "Installing demos from $(srcdir)/demos into $(DATA_DIR)/demos"
+ @for i in $(srcdir)/demos/*; \
+ do \
+ if [ -f $$i ] ; then \
+- $(INSTALL_SCRIPT) $$i $(SCRIPT_INSTALL_DIR)/demos; \
++ $(INSTALL_SCRIPT) $$i $(DATA_DIR)/demos; \
+ fi; \
+ done;
+- @echo "Installing images from $(srcdir)/demos/images into $(SCRIPT_INSTALL_DIR)/demos/images"
++ @echo "Installing images from $(srcdir)/demos/images into $(DATA_DIR)/demos/images"
+ for i in $(srcdir)/demos/images/*; \
+ do \
+ if [ -f $$i ] ; then \
+- $(INSTALL_DATA) $$i $(SCRIPT_INSTALL_DIR)/demos/images; \
++ $(INSTALL_DATA) $$i $(DATA_DIR)/demos/images; \
+ fi; \
+ done;
+- @echo "Installing html man pages from $(srcdir)/demos/html into $(SCRIPT_INSTALL_DIR)/demos/html"
++ @echo "Installing html man pages from $(srcdir)/demos/html into $(DATA_DIR)/demos/html"
+ for i in $(srcdir)/demos/html/*; \
+ do \
+ if [ -f $$i ] ; then \
+- $(INSTALL_DATA) $$i $(SCRIPT_INSTALL_DIR)/demos/html; \
++ $(INSTALL_DATA) $$i $(DATA_DIR)/demos/html; \
+ fi; \
+ done;
+
+@@ -169,7 +172,6 @@
+ $$i > $(MAN_INSTALL_DIR)/`basename iwidgets_$$i`; \
+ chmod 444 $(MAN_INSTALL_DIR)/`basename iwidgets_$$i`; \
+ done;
+- $(INSTALL_DATA) $(srcdir)/license.terms $(SCRIPT_INSTALL_DIR)
+
+ Makefile: $(srcdir)/Makefile.in
+ $(SHELL) config.status