summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-tcltk/iwidgets/iwidgets-4.0.1.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-tcltk/iwidgets/iwidgets-4.0.1.ebuild')
-rw-r--r--dev-tcltk/iwidgets/iwidgets-4.0.1.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/dev-tcltk/iwidgets/iwidgets-4.0.1.ebuild b/dev-tcltk/iwidgets/iwidgets-4.0.1.ebuild
new file mode 100644
index 000000000000..428a22f66928
--- /dev/null
+++ b/dev-tcltk/iwidgets/iwidgets-4.0.1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+MY_P=${PN}${PV}
+ITCL_MY_PN="itcl"
+ITCL_MY_PV="3.2.1"
+ITCL_MY_P="${ITCL_MY_PN}${ITCL_MY_PV}"
+
+DESCRIPTION="Widget collection for incrTcl/incrTk"
+HOMEPAGE="http://incrtcl.sourceforge.net/itcl/"
+SRC_URI="
+ mirror://sourceforge/incrtcl/${MY_P}.tar.gz
+ mirror://sourceforge/incrtcl/${ITCL_MY_P}_src.tgz"
+
+LICENSE="HPND Old-MIT tcltk"
+SLOT="0"
+KEYWORDS="~alpha amd64 ia64 ppc sparc x86"
+IUSE=""
+
+DEPEND="
+ >=dev-tcltk/itcl-3.2.1
+ >=dev-tcltk/itk-3.3-r1"
+RDEPEND="${DEPEND}"
+
+S=${WORKDIR}/${MY_P}
+
+src_compile() {
+ local myconf
+ myconf="${myconf} --with-itcl=${WORKDIR}/${ITCL_MY_P}"
+ econf ${myconf}
+}
+
+src_install() {
+ einstall || die "einstall failed"
+ dodoc CHANGES ChangeLog README || die
+ # Bug 115470
+ rm doc/panedwindow.n
+ doman doc/*.n || die
+}