summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2023-03-15 22:11:27 +0100
committerAlfredo Tupone <tupone@gentoo.org>2023-03-15 22:12:24 +0100
commit281535f88931fec48c2dd2fa3a8f4f3cfac201b0 (patch)
tree9fd5c1fc6aa896349b1e75ba272f711010234a85 /dev-tcltk/tclx/files
parentdev-python/nbconvert: Keyword 7.2.10 ia64, #901233 (diff)
downloadgentoo-281535f88931fec48c2dd2fa3a8f4f3cfac201b0.tar.gz
gentoo-281535f88931fec48c2dd2fa3a8f4f3cfac201b0.tar.bz2
gentoo-281535f88931fec48c2dd2fa3a8f4f3cfac201b0.zip
dev-tcltk/tclx: filter rresvport if not present
Closes: https://bugs.gentoo.org/894176 Signed-off-by: Alfredo Tupone <tupone@gentoo.org>
Diffstat (limited to 'dev-tcltk/tclx/files')
-rw-r--r--dev-tcltk/tclx/files/tclx-8.4.4-musl.patch25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-tcltk/tclx/files/tclx-8.4.4-musl.patch b/dev-tcltk/tclx/files/tclx-8.4.4-musl.patch
new file mode 100644
index 000000000000..2fc45e05b6ab
--- /dev/null
+++ b/dev-tcltk/tclx/files/tclx-8.4.4-musl.patch
@@ -0,0 +1,25 @@
+--- a/configure.in 2023-03-15 22:00:11.725506240 +0100
++++ b/configure.in 2023-03-15 22:00:29.230246904 +0100
+@@ -253,6 +253,7 @@
+
+ AC_CHECK_FUNC(inet_aton, , [AC_DEFINE(NO_INET_ATON)])
+ AC_CHECK_FUNC(gethostname, , [AC_DEFINE(NO_GETHOSTNAME)])
++ AC_CHECK_FUNCS([rresvport])
+
+ #-------------------------------------------------------------------------
+ # Check for additional libraries the Tcl/Tk does not check for.
+--- a/unix/tclXunixSock.c 2023-03-15 22:02:32.255424538 +0100
++++ b/unix/tclXunixSock.c 2023-03-15 22:03:35.094493443 +0100
+@@ -194,10 +194,12 @@
+ * Allocate a reserved port if requested.
+ */
+ if (getReserved) {
++#ifdef HAVE_RRESVPORT
+ int port;
+ if (rresvport (&port) < 0)
+ goto unixError;
+ local.sin_port = port;
++#endif
+ }
+
+ /*