summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-10-04 06:44:57 +0100
committerSam James <sam@gentoo.org>2022-10-04 08:09:24 +0100
commitb13076bbf4041bdd1af92001b72c8a64e0511084 (patch)
tree74660a3708179db14c2bbcc5fb5587834d8da20c /dev-tcltk/tktray
parentdev-libs/pslib: add 0.4.6 (diff)
downloadgentoo-b13076bbf4041bdd1af92001b72c8a64e0511084.tar.gz
gentoo-b13076bbf4041bdd1af92001b72c8a64e0511084.tar.bz2
gentoo-b13076bbf4041bdd1af92001b72c8a64e0511084.zip
dev-tcltk/tktray: EAPI 8, fix configure w/ Clang 16
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-tcltk/tktray')
-rw-r--r--dev-tcltk/tktray/tktray-1.3.9-r1.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/dev-tcltk/tktray/tktray-1.3.9-r1.ebuild b/dev-tcltk/tktray/tktray-1.3.9-r1.ebuild
new file mode 100644
index 000000000000..abfcf148c17d
--- /dev/null
+++ b/dev-tcltk/tktray/tktray-1.3.9-r1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+DESCRIPTION="System Tray Icon Support for Tk on X11"
+HOMEPAGE="https://code.google.com/p/tktray/"
+SRC_URI="https://tktray.googlecode.com/files/${PN}${PV}.tar.gz"
+S="${WORKDIR}/${PN}${PV}"
+
+LICENSE="tcltk"
+SLOT="0"
+KEYWORDS="amd64 ~ppc ~sparc x86"
+IUSE="debug threads"
+
+# tests need actual X server with user interaction, bug #284919
+RESTRICT="test"
+
+DEPEND="
+ >=dev-lang/tcl-8.4:=
+ >=dev-lang/tk-8.4:=
+ x11-libs/libXext"
+RDEPEND="${DEPEND}"
+
+PATCHES=(
+ "${FILESDIR}"/1.1-ldflags.patch
+)
+
+src_prepare() {
+ default
+
+ # Fix bad configure tests w/ Clang 16
+ eautoreconf
+}
+
+src_configure() {
+ source "${BROOT}"/usr/lib/tclConfig.sh || die
+
+ CPPFLAGS="-I${TCL_SRC_DIR}/generic ${CPPFLAGS}" \
+ econf \
+ $(use_enable debug symbols) \
+ $(use_enable threads)
+}