summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2021-02-26 20:04:30 +0100
committerAlfredo Tupone <tupone@gentoo.org>2021-02-26 20:10:16 +0100
commit31a27d4ac18f40f9a8bc25630271c2f13fd9fe51 (patch)
treeb65e53b5d1b653d539c48639354456f0cfcdf325 /dev-tcltk
parentsys-kernel/gentoo-kernel-bin: Bump to 5.10.19 (diff)
downloadgentoo-31a27d4ac18f40f9a8bc25630271c2f13fd9fe51.tar.gz
gentoo-31a27d4ac18f40f9a8bc25630271c2f13fd9fe51.tar.bz2
gentoo-31a27d4ac18f40f9a8bc25630271c2f13fd9fe51.zip
dev-tcltk/tclreadline: fix 64 bit location
Package-Manager: Portage-3.0.13, Repoman-3.0.2 Signed-off-by: Alfredo Tupone <tupone@gentoo.org>
Diffstat (limited to 'dev-tcltk')
-rw-r--r--dev-tcltk/tclreadline/tclreadline-2.3.8-r1.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/dev-tcltk/tclreadline/tclreadline-2.3.8-r1.ebuild b/dev-tcltk/tclreadline/tclreadline-2.3.8-r1.ebuild
new file mode 100644
index 000000000000..8d94f9c47fb3
--- /dev/null
+++ b/dev-tcltk/tclreadline/tclreadline-2.3.8-r1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 2020-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Readline extension to TCL"
+HOMEPAGE="https://github.com/flightaware/tclreadline"
+SRC_URI="https://github.com/flightaware/tclreadline/archive/v${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="tk"
+
+DEPEND="dev-lang/tcl:0=
+ sys-libs/readline:0=
+ tk? ( dev-lang/tk:0= )"
+RDEPEND="${DEPEND}"
+BDEPEND=""
+
+src_prepare() {
+ default
+ sed -i \
+ -e "s|^\(TCLRL_LIBDIR\)=.*|\1=\"${EPREFIX}/usr/$(get_libdir)\"|" \
+ configure || die
+}
+
+src_configure() {
+ local myConf=--with-tcl="${EPREFIX}/usr/$(get_libdir)"
+ if ! use tk; then
+ myConf="$myConf --without-tk"
+ fi
+ econf $myConf
+}
+
+src_install() {
+ default
+ find "${D}" -name \*.la -delete
+}