summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTupone Alfredo <tupone@gentoo.org>2019-10-12 15:15:05 +0200
committerTupone Alfredo <tupone@gentoo.org>2019-10-12 15:15:05 +0200
commit4e628bf0e6f9e6a583419d9ae4a885a9e8b36177 (patch)
tree39d59c3636d3d42996f448d4f9e11df14991c1b9 /dev-tcltk
parentbsdmk.eclass: Drop to maintainer-needed (diff)
downloadgentoo-4e628bf0e6f9e6a583419d9ae4a885a9e8b36177.tar.gz
gentoo-4e628bf0e6f9e6a583419d9ae4a885a9e8b36177.tar.bz2
gentoo-4e628bf0e6f9e6a583419d9ae4a885a9e8b36177.zip
dev-tcltk/scwoop: EAPI 7
Bug: https://bugs.gentoo.org/697338 Package-Manager: Portage-2.3.69, Repoman-2.3.16 Signed-off-by: Alfredo Tupone <tupone@gentoo.org>
Diffstat (limited to 'dev-tcltk')
-rw-r--r--dev-tcltk/scwoop/scwoop-4.1-r1.ebuild28
-rw-r--r--dev-tcltk/scwoop/scwoop-4.1.ebuild1
2 files changed, 29 insertions, 0 deletions
diff --git a/dev-tcltk/scwoop/scwoop-4.1-r1.ebuild b/dev-tcltk/scwoop/scwoop-4.1-r1.ebuild
new file mode 100644
index 000000000000..16a2cf48043c
--- /dev/null
+++ b/dev-tcltk/scwoop/scwoop-4.1-r1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Simple Composite Widget Object Oriented Package"
+HOMEPAGE="http://jfontain.free.fr/scwoop41.htm"
+SRC_URI="http://jfontain.free.fr/${P}.tar.gz"
+
+LICENSE="jfontain"
+KEYWORDS="~amd64 ~ppc ~x86"
+SLOT="0"
+IUSE=""
+
+DEPEND="dev-tcltk/tcllib"
+RDEPEND="${DEPEND}"
+
+HTML_DOCS=( scwoop.htm )
+
+src_install() {
+ dodir /usr/lib/scwoop
+ ./instapkg.tcl "${D}"/usr/lib/scwoop || die
+
+ einstalldocs
+ docompress -x /usr/share/doc/${PF}/demo
+ docinto demo
+ dodoc demo*
+}
diff --git a/dev-tcltk/scwoop/scwoop-4.1.ebuild b/dev-tcltk/scwoop/scwoop-4.1.ebuild
index 6a61670703e9..13f55586d5e3 100644
--- a/dev-tcltk/scwoop/scwoop-4.1.ebuild
+++ b/dev-tcltk/scwoop/scwoop-4.1.ebuild
@@ -13,6 +13,7 @@ SLOT="0"
IUSE=""
DEPEND="dev-tcltk/tcllib"
+RDEPEND="${DEPEND}"
src_install() {
dodir /usr/lib/scwoop