summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2024-02-24 21:13:15 +0100
committerAlfredo Tupone <tupone@gentoo.org>2024-02-24 21:14:31 +0100
commit5d7adf81044dbe3e035815dc85fa1127fa811970 (patch)
treef3a2ee141c715395f5b80a170e53641e999fe395 /dev-tcltk
parentapp-arch/torrentzip: drop 1.0 (diff)
downloadgentoo-5d7adf81044dbe3e035815dc85fa1127fa811970.tar.gz
gentoo-5d7adf81044dbe3e035815dc85fa1127fa811970.tar.bz2
gentoo-5d7adf81044dbe3e035815dc85fa1127fa811970.zip
dev-tcltk/tclxml: fix incompatible function pointer
Closes: https://bugs.gentoo.org/924861 Signed-off-by: Alfredo Tupone <tupone@gentoo.org>
Diffstat (limited to 'dev-tcltk')
-rw-r--r--dev-tcltk/tclxml/files/tclxml-3.3.1-funcPointer.patch38
-rw-r--r--dev-tcltk/tclxml/tclxml-3.3.1-r1.ebuild3
2 files changed, 40 insertions, 1 deletions
diff --git a/dev-tcltk/tclxml/files/tclxml-3.3.1-funcPointer.patch b/dev-tcltk/tclxml/files/tclxml-3.3.1-funcPointer.patch
new file mode 100644
index 000000000000..3f641b490883
--- /dev/null
+++ b/dev-tcltk/tclxml/files/tclxml-3.3.1-funcPointer.patch
@@ -0,0 +1,38 @@
+From c1bc95aadd5334adf9c6d17ce918abf98af14c6f Mon Sep 17 00:00:00 2001
+From: Alfredo Tupone <tupone@gentoo.org>
+Date: Sat, 24 Feb 2024 20:38:49 +0100
+Subject: [PATCH] fix -Wincompatible-pointer-types
+
+---
+ docObj.c | 4 +---
+ include/tclxml-libxml2/tclxml-libxml2Decls.h | 2 +-
+ 2 files changed, 2 insertions(+), 4 deletions(-)
+
+diff --git a/docObj.c b/docObj.c
+index 20a1bd4..c4d5bf9 100644
+--- a/docObj.c
++++ b/docObj.c
+@@ -1852,9 +1852,7 @@ ErrorCodeToString(code)
+ }
+
+ void
+-TclXML_libxml2_ErrorHandler (ctx, error)
+- void *ctx; /* ignore - depends on context */
+- xmlErrorPtr error;
++TclXML_libxml2_ErrorHandler (void *ctx, const xmlError *error)
+ {
+ ThreadSpecificData *tsdPtr = Tcl_GetThreadData(&dataKey, sizeof(ThreadSpecificData));
+ Tcl_Obj *objPtr;
+diff --git a/include/tclxml-libxml2/tclxml-libxml2Decls.h b/include/tclxml-libxml2/tclxml-libxml2Decls.h
+index 3faa5f7..9ad6555 100644
+--- a/include/tclxml-libxml2/tclxml-libxml2Decls.h
++++ b/include/tclxml-libxml2/tclxml-libxml2Decls.h
+@@ -55,7 +55,7 @@ EXTERN void TclXML_libxml2_DocKeep _ANSI_ARGS_((Tcl_Obj * objPtr,
+ TclXML_libxml2_DocumentHandling keep));
+ /* 10 */
+ EXTERN void TclXML_libxml2_ErrorHandler _ANSI_ARGS_((void * ctx,
+- xmlErrorPtr error));
++ const xmlError *error));
+ /* 11 */
+ EXTERN void TclXML_libxml2_ResetError _ANSI_ARGS_((
+ Tcl_Interp * interp));
diff --git a/dev-tcltk/tclxml/tclxml-3.3.1-r1.ebuild b/dev-tcltk/tclxml/tclxml-3.3.1-r1.ebuild
index c6aed4cf1018..2091c6704dab 100644
--- a/dev-tcltk/tclxml/tclxml-3.3.1-r1.ebuild
+++ b/dev-tcltk/tclxml/tclxml-3.3.1-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -29,6 +29,7 @@ RESTRICT="test"
PATCHES=(
"${FILESDIR}"/${PN}-3.2-fix-implicit-declarations.patch
+ "${FILESDIR}"/${P}-funcPointer.patch
)
S="${WORKDIR}"/${MYP}