summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-05-27 11:53:21 +0100
committerSam James <sam@gentoo.org>2023-05-27 11:53:44 +0100
commit99978aef91ce40c35a94f4286f4309f0f236e32b (patch)
tree4b0deb95e1946add2ba314287c66e5283172148b /dev-tcltk
parentmedia-gfx/feh: Stabilize 3.10 ppc, #906850 (diff)
downloadgentoo-99978aef91ce40c35a94f4286f4309f0f236e32b.tar.gz
gentoo-99978aef91ce40c35a94f4286f4309f0f236e32b.tar.bz2
gentoo-99978aef91ce40c35a94f4286f4309f0f236e32b.zip
dev-tcltk/tclx: add 8.6.1
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-tcltk')
-rw-r--r--dev-tcltk/tclx/Manifest1
-rw-r--r--dev-tcltk/tclx/files/tclx-8.4.4-musl.patch1
-rw-r--r--dev-tcltk/tclx/tclx-8.6.1.ebuild60
3 files changed, 62 insertions, 0 deletions
diff --git a/dev-tcltk/tclx/Manifest b/dev-tcltk/tclx/Manifest
index dc4959ca2a22..b3aecab75124 100644
--- a/dev-tcltk/tclx/Manifest
+++ b/dev-tcltk/tclx/Manifest
@@ -1 +1,2 @@
DIST tclx-8.4.4.tar.gz 456569 BLAKE2B 50123f95ed780c28dae9e2f0db956b81b559ee9ea33563b999f33a727c451374a63c0cba3012d4dd46df020426c7fdb3b04f932fc5b6ec742156e9dad81a7d3b SHA512 dcf9cbd08eae0cc4901e8e871a440e6c85d7d5ac923306206afaf0a1d931866ce3b91177d7b3a37e87a5cdcccb068ed7b9c76cb1a71a13f4f26cf204b8c42090
+DIST tclx-8.6.1.tar.gz 457438 BLAKE2B 451b90a6f4403177604684a2a4475a057924faa4b625ac035d65b622b69e8dfea7146143056491ce8740374c18c4fbfb0184a0d074bf799897a01bb767e1695c SHA512 4a2293aad667b108f19f837686044fc168831781d04a9f8eaa2afe677c587f1e128a536ad9db609720e0046a20ff6f8dd7a0e5dd1232ef775c5a14e24ec0614d
diff --git a/dev-tcltk/tclx/files/tclx-8.4.4-musl.patch b/dev-tcltk/tclx/files/tclx-8.4.4-musl.patch
index 2fc45e05b6ab..301ad263b558 100644
--- a/dev-tcltk/tclx/files/tclx-8.4.4-musl.patch
+++ b/dev-tcltk/tclx/files/tclx-8.4.4-musl.patch
@@ -1,3 +1,4 @@
+https://github.com/flightaware/tclx/pull/16#issuecomment-1565348180
--- a/configure.in 2023-03-15 22:00:11.725506240 +0100
+++ b/configure.in 2023-03-15 22:00:29.230246904 +0100
@@ -253,6 +253,7 @@
diff --git a/dev-tcltk/tclx/tclx-8.6.1.ebuild b/dev-tcltk/tclx/tclx-8.6.1.ebuild
new file mode 100644
index 000000000000..ec341dace231
--- /dev/null
+++ b/dev-tcltk/tclx/tclx-8.6.1.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+DESCRIPTION="A set of extensions to TCL"
+HOMEPAGE="http://tclx.sourceforge.net"
+SRC_URI="https://github.com/flightaware/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux"
+IUSE="threads"
+
+DEPEND="dev-lang/tcl:0="
+RDEPEND="${DEPEND}"
+
+# tests broken, bug #279283
+RESTRICT="test"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-8.4-varinit.patch
+ "${FILESDIR}"/${PN}-8.4-ldflags.patch
+ "${FILESDIR}"/${PN}-8.4.4-musl.patch
+)
+
+QA_CONFIG_IMPL_DECL_SKIP=(
+ stat64 # used to test for Large File Support
+)
+
+src_prepare() {
+ default
+
+ sed \
+ -e '/CC=/s:-pipe::g' \
+ -i tclconfig/tcl.m4 configure || die
+
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_enable threads) \
+ --enable-shared \
+ --with-tcl="${EPREFIX}/usr/$(get_libdir)/"
+
+ # adjust install_name on darwin
+ if [[ ${CHOST} == *-darwin* ]]; then
+ sed -i \
+ -e 's:^\(SHLIB_LD\W.*\)$:\1 -install_name ${pkglibdir}/$@:' \
+ "${S}"/Makefile || die 'sed failed'
+ fi
+}
+
+src_install() {
+ default
+ doman doc/*.[n3]
+}