summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-04-16 22:36:29 +0100
committerSam James <sam@gentoo.org>2021-04-18 07:01:38 +0100
commitbf613eeab32137f37b77465f626ca1d5f565d70f (patch)
treeb08f80fb0ca8ec6509683bace74d2bfcfed88cb5 /dev-tcltk
parentdev-tcltk/tdom: eutils->epatch (diff)
downloadgentoo-bf613eeab32137f37b77465f626ca1d5f565d70f.tar.gz
gentoo-bf613eeab32137f37b77465f626ca1d5f565d70f.tar.bz2
gentoo-bf613eeab32137f37b77465f626ca1d5f565d70f.zip
dev-tcltk/tdom: multilib--, fix PATCHES formatting
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-tcltk')
-rw-r--r--dev-tcltk/tdom/tdom-0.8.3-r4.ebuild16
-rw-r--r--dev-tcltk/tdom/tdom-0.9.1.ebuild2
2 files changed, 10 insertions, 8 deletions
diff --git a/dev-tcltk/tdom/tdom-0.8.3-r4.ebuild b/dev-tcltk/tdom/tdom-0.8.3-r4.ebuild
index dc224f4c762c..735ee6d3da33 100644
--- a/dev-tcltk/tdom/tdom-0.8.3-r4.ebuild
+++ b/dev-tcltk/tdom/tdom-0.8.3-r4.ebuild
@@ -25,22 +25,24 @@ RDEPEND="${DEPEND}"
S="${WORKDIR}/${MY_P}"
PATCHES=(
- "${FILESDIR}/"${PN}-0.8.2.patch
- "${FILESDIR}/"${P}-soname.patch
- "${FILESDIR}/"${P}-expat.patch
- "${FILESDIR}/"${PN}-0.8.2-tnc.patch
- "${FILESDIR}/"${P}-tcl8.6.patch
- )
+ "${FILESDIR}"/${PN}-0.8.2.patch
+ "${FILESDIR}"/${P}-soname.patch
+ "${FILESDIR}"/${P}-expat.patch
+ "${FILESDIR}"/${PN}-0.8.2-tnc.patch
+ "${FILESDIR}"/${P}-tcl8.6.patch
+)
src_prepare() {
tc-export AR
append-libs -lm
+
sed \
-e 's:-O2::g' \
-e 's:-pipe::g' \
-e 's:-fomit-frame-pointer::g' \
-e '/SHLIB_LD_LIBS/s:\"$: ${TCL_LIB_FLAG}":g' \
-i {.,extensions/tnc}/configure tclconfig/tcl.m4 || die
+
epatch "${PATCHES[@]}"
eautoreconf
}
@@ -52,7 +54,7 @@ src_configure() {
--disable-tdomalloc
--with-expat
--with-tcl="${EPREFIX}"/usr/$(get_libdir)
- )
+ )
cd "${S}"/unix && ECONF_SOURCE=".." econf ${myeconfargs}
cd "${S}"/extensions/tdomhtml && econf ${myeconfargs}
diff --git a/dev-tcltk/tdom/tdom-0.9.1.ebuild b/dev-tcltk/tdom/tdom-0.9.1.ebuild
index 7c3428358956..d97f40d5074f 100644
--- a/dev-tcltk/tdom/tdom-0.9.1.ebuild
+++ b/dev-tcltk/tdom/tdom-0.9.1.ebuild
@@ -3,7 +3,7 @@
EAPI=6
-inherit autotools flag-o-matic multilib toolchain-funcs
+inherit autotools flag-o-matic toolchain-funcs
MY_P="tDOM-${PV}"