summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2021-04-12 20:32:31 +0200
committerAlfredo Tupone <tupone@gentoo.org>2021-04-12 20:32:59 +0200
commitc09e69967977655d8bd5664265441ddb81194669 (patch)
treef9857a1bd81355be134bad32f50f52ab43d15bcd /dev-tcltk
parentapp-arch/rar: bump to v6.0.1 from 2021-04-07 (diff)
downloadgentoo-c09e69967977655d8bd5664265441ddb81194669.tar.gz
gentoo-c09e69967977655d8bd5664265441ddb81194669.tar.bz2
gentoo-c09e69967977655d8bd5664265441ddb81194669.zip
dev-tcltk/tclpython: support python3.8
Package-Manager: Portage-3.0.13, Repoman-3.0.2 Signed-off-by: Alfredo Tupone <tupone@gentoo.org>
Diffstat (limited to 'dev-tcltk')
-rw-r--r--dev-tcltk/tclpython/tclpython-5.0-r1.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/dev-tcltk/tclpython/tclpython-5.0-r1.ebuild b/dev-tcltk/tclpython/tclpython-5.0-r1.ebuild
new file mode 100644
index 000000000000..001d6e864a21
--- /dev/null
+++ b/dev-tcltk/tclpython/tclpython-5.0-r1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_8 )
+
+inherit multilib python-single-r1 toolchain-funcs
+
+DESCRIPTION="Python package for Tcl"
+HOMEPAGE="http://jfontain.free.fr/tclpython.htm"
+SRC_URI="https://github.com/amykyta3/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+DEPEND="${PYTHON_DEPS}
+ dev-lang/tcl:0="
+RDEPEND="${DEPEND}"
+
+PATCHES=( "${FILESDIR}"/${P}-gentoo.patch )
+
+src_compile() {
+ emake PKG_NAME=tclpython3 CC=$(tc-getCC) \
+ MYCFLAGS="${CFLAGS}" \
+ MYLDFLAGS="${LDFLAGS} $(python_get_library_path)"
+}
+
+src_test() {
+ emake PKG_NAME=tclpython3 CC=$(tc-getCC) test
+}
+
+src_install() {
+ insinto /usr/$(get_libdir)
+ doins -r build/tclpython3/tclpython3
+ fperms 775 /usr/$(get_libdir)/tclpython3/tclpython3.so.${PV}
+ dosym tclpython3.so.${PV} /usr/$(get_libdir)/tclpython3/tclpython3.so
+
+ dodoc README.md VERSION.md
+}