summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-tex/dot2tex
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-tex/dot2tex')
-rw-r--r--dev-tex/dot2tex/Manifest2
-rw-r--r--dev-tex/dot2tex/dot2tex-2.8.7-r1.ebuild36
-rw-r--r--dev-tex/dot2tex/dot2tex-2.8.7.ebuild38
-rw-r--r--dev-tex/dot2tex/dot2tex-2.9.0.ebuild44
-rw-r--r--dev-tex/dot2tex/metadata.xml9
5 files changed, 129 insertions, 0 deletions
diff --git a/dev-tex/dot2tex/Manifest b/dev-tex/dot2tex/Manifest
new file mode 100644
index 000000000000..5b7966dd2b30
--- /dev/null
+++ b/dev-tex/dot2tex/Manifest
@@ -0,0 +1,2 @@
+DIST dot2tex-2.8.7.tar.gz 571055 SHA256 899168d976faff8768115648a1371bcb92c81e14cf371cafec056eff398d56d7 SHA512 a74bf94e295571f066b836848a583c35c15a16117cb86dd849c6ba1ec1f9ebf815cdd3b5641f90740d0fc108819794d1960a240ad6838a189faac3889d0b7527 WHIRLPOOL c71d1d1140b67669940e8a565435a7d8deea8ce70a5b33cee97b4d1dcb27b005fcb245494bf7189e49c2f8824ee6b0154cb4aebf4799ea04c76cbbefc02113b9
+DIST dot2tex-2.9.0.tar.gz 663372 SHA256 7a182868f72fd5e59899f85006c3b559ac4157ade003f3e208341a9a5b46d2fa SHA512 97ba9983643254d5a3034d2fc8c454c445849ac546bd285676b854e20c8aae9a25d61e73632717da1562541ce9b3a4ae8aa4daa29e33f78105e28a34b5ebae5d WHIRLPOOL 22e8be55034cfda62091d1de7de34a07ccba9d695d41b18a9edf688d16c2219b24cba842344f1c3f7dd86b3a8293b8c94ccacba93097c46d7ab5d0407b03f88b
diff --git a/dev-tex/dot2tex/dot2tex-2.8.7-r1.ebuild b/dev-tex/dot2tex/dot2tex-2.8.7-r1.ebuild
new file mode 100644
index 000000000000..40b9bfd1092e
--- /dev/null
+++ b/dev-tex/dot2tex/dot2tex-2.8.7-r1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="A Graphviz to LaTeX converter"
+HOMEPAGE="http://www.fauskes.net/code/dot2tex/"
+SRC_URI="http://dot2tex.googlecode.com/files/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd ~amd64-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris"
+IUSE="doc examples"
+
+DEPEND=""
+RDEPEND="dev-python/pyparsing[${PYTHON_USEDEP}]
+ media-gfx/pydot[${PYTHON_USEDEP}]
+ media-gfx/graphviz"
+
+python_install_all() {
+ distutils-r1_python_install_all
+
+ if use doc; then
+ dohtml -r doc/*
+ dodoc doc/usage.{txt,pdf}
+ fi
+ if use examples; then
+ dodoc -r examples
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+}
diff --git a/dev-tex/dot2tex/dot2tex-2.8.7.ebuild b/dev-tex/dot2tex/dot2tex-2.8.7.ebuild
new file mode 100644
index 000000000000..9b582b6fbc7f
--- /dev/null
+++ b/dev-tex/dot2tex/dot2tex-2.8.7.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="3"
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.*"
+
+inherit distutils
+
+DESCRIPTION="A Graphviz to LaTeX converter"
+HOMEPAGE="http://www.fauskes.net/code/dot2tex/"
+SRC_URI="http://dot2tex.googlecode.com/files/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 s390 sh sparc x86 ~x86-fbsd ~amd64-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris"
+IUSE="doc examples"
+
+DEPEND=""
+RDEPEND="dev-python/pyparsing
+ media-gfx/pydot
+ media-gfx/graphviz"
+
+DOCS="changelog.txt"
+
+src_install() {
+ distutils_src_install
+ if use doc; then
+ dohtml -r doc/*
+ dodoc doc/usage.{txt,pdf}
+ fi
+ if use examples; then
+ insinto "/usr/share/doc/${PF}/examples"
+ doins examples/*
+ fi
+}
diff --git a/dev-tex/dot2tex/dot2tex-2.9.0.ebuild b/dev-tex/dot2tex/dot2tex-2.9.0.ebuild
new file mode 100644
index 000000000000..f35ba7f44e9f
--- /dev/null
+++ b/dev-tex/dot2tex/dot2tex-2.9.0.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="A Graphviz to LaTeX converter"
+HOMEPAGE="https://dot2tex.readthedocs.org/ https://github.com/kjellmf/dot2tex"
+SRC_URI="https://github.com/kjellmf/dot2tex/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd ~amd64-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris"
+IUSE="doc examples"
+
+DEPEND="dev-python/pyparsing[${PYTHON_USEDEP}]"
+RDEPEND="
+ media-gfx/pydot[${PYTHON_USEDEP}]
+ media-gfx/graphviz"
+DEPEND="${DEPEND}
+ doc? ( dev-python/sphinx )"
+
+python_compile_all() {
+ if use doc ; then
+ cd "${S}/docs"
+ emake html
+ fi
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+
+ if use doc; then
+ dohtml -r docs/_build/html/*
+ fi
+ if use examples; then
+ dodoc -r examples
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+}
diff --git a/dev-tex/dot2tex/metadata.xml b/dev-tex/dot2tex/metadata.xml
new file mode 100644
index 000000000000..73c319c8eb2f
--- /dev/null
+++ b/dev-tex/dot2tex/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>tex</herd>
+ <upstream>
+ <remote-id type="google-code">dot2tex</remote-id>
+ <remote-id type="github">kjellmf/dot2tex</remote-id>
+ </upstream>
+</pkgmetadata>