summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2016-01-07 08:47:46 +0100
committerAlexis Ballier <aballier@gentoo.org>2016-01-07 08:47:46 +0100
commit5c88ed2bd0d8c4852b2a1f719c1574858de83d11 (patch)
tree04e0f42093ea891472f5745be1c731a101c90acb /dev-tex/hevea/hevea-2.28.ebuild
parentmedia-sound/qtractor: bump to 0.7.3 (diff)
downloadgentoo-5c88ed2bd0d8c4852b2a1f719c1574858de83d11.tar.gz
gentoo-5c88ed2bd0d8c4852b2a1f719c1574858de83d11.tar.bz2
gentoo-5c88ed2bd0d8c4852b2a1f719c1574858de83d11.zip
dev-tex/hevea: bump to 2.28
Package-Manager: portage-2.2.26 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-tex/hevea/hevea-2.28.ebuild')
-rw-r--r--dev-tex/hevea/hevea-2.28.ebuild58
1 files changed, 58 insertions, 0 deletions
diff --git a/dev-tex/hevea/hevea-2.28.ebuild b/dev-tex/hevea/hevea-2.28.ebuild
new file mode 100644
index 000000000000..90a000220df6
--- /dev/null
+++ b/dev-tex/hevea/hevea-2.28.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils multilib
+
+IUSE="+ocamlopt"
+
+DESCRIPTION="HeVeA is a quite complete and fast LaTeX to HTML translator"
+HOMEPAGE="http://hevea.inria.fr/"
+SRC_URI="http://hevea.inria.fr/distri/${P}.tar.gz"
+
+LICENSE="QPL"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+
+DEPEND=">=dev-lang/ocaml-3.12:=[ocamlopt?]"
+RDEPEND="${DEPEND}
+ dev-texlive/texlive-latexextra"
+
+src_compile() {
+ rm -f config.sh
+ emake PREFIX=/usr DESTDIR="${D}" LIBDIR="/usr/$(get_libdir)/hevea" LATEXLIBDIR="/usr/share/texmf-site/tex/latex/hevea" config.sh || die "Failed to create config.sh"
+ if use ocamlopt; then
+ emake PREFIX=/usr || die "Failed to build native code binaries"
+ else
+ emake PREFIX=/usr TARGET=byte || die "Failed to build bytecode binaries"
+ fi
+}
+
+src_install() {
+ if use ocamlopt; then
+ emake DESTDIR="${D}" PREFIX=/usr install || die "Install failed"
+ else
+ emake DESTDIR="${D}" PREFIX=/usr TARGET=byte install || die "Install failed"
+ fi
+
+ dodoc README CHANGES
+}
+
+# If texmf-update is present this means we have a latex install; update it so
+# that hevea.sty can be found
+# Do not (r)depend on latex though because hevea does not need it itself
+# If latex is installed later, it will see hevea.sty
+
+pkg_postinst() {
+ if [ "$ROOT" = "/" ] && [ -x /usr/sbin/texmf-update ] ; then
+ /usr/sbin/texmf-update
+ fi
+}
+
+pkg_postrm() {
+ if [ "$ROOT" = "/" ] && [ -x /usr/sbin/texmf-update ] ; then
+ /usr/sbin/texmf-update
+ fi
+}