summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2021-11-24 19:04:05 +0100
committerMarek Szuba <marecki@gentoo.org>2021-11-24 19:06:32 +0100
commit2b44f61641dc5b6452fa646ef7df44fa0f01846b (patch)
treee78a0a70c668b9811286770f556714ba47ede4cc /dev-tex/html2latex/html2latex-1.1-r2.ebuild
parentdev-libs/lockdev: do not hardcode glibc-specific major() and minor() (diff)
downloadgentoo-2b44f61641dc5b6452fa646ef7df44fa0f01846b.tar.gz
gentoo-2b44f61641dc5b6452fa646ef7df44fa0f01846b.tar.bz2
gentoo-2b44f61641dc5b6452fa646ef7df44fa0f01846b.zip
dev-tex/html2latex: update EAPI 5 -> 8
Closes: https://bugs.gentoo.org/484432 Bug: https://bugs.gentoo.org/819597 Signed-off-by: Marek Szuba <marecki@gentoo.org>
Diffstat (limited to 'dev-tex/html2latex/html2latex-1.1-r2.ebuild')
-rw-r--r--dev-tex/html2latex/html2latex-1.1-r2.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/dev-tex/html2latex/html2latex-1.1-r2.ebuild b/dev-tex/html2latex/html2latex-1.1-r2.ebuild
new file mode 100644
index 000000000000..1321a9313436
--- /dev/null
+++ b/dev-tex/html2latex/html2latex-1.1-r2.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit perl-module
+
+DESCRIPTION="Perl script to convert HTML files into formatted LaTeX"
+HOMEPAGE="http://html2latex.sourceforge.net/"
+SRC_URI="mirror://sourceforge/project/${PN}/${PN}/${PV}/${P}.tar.gz"
+LICENSE="GPL-2"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+
+IUSE="imagemagick libwww"
+
+DEPEND="dev-perl/HTML-Tree
+ dev-perl/XML-Simple
+ imagemagick? ( media-gfx/imagemagick )
+ libwww? ( dev-perl/libwww-perl )"
+
+src_compile() {
+ # HTML::LaTex
+ cd HTML
+ perl-module_src_configure
+ perl-module_src_compile
+}
+
+src_install() {
+ dobin html2latex
+ doman html2latex.1
+ dodoc README TODO
+
+ # HTML::LaTex
+ cd HTML
+ perl-module_src_install
+ # rm unwanted README.win
+ rm "${ED}"/usr/share/doc/${PF}/README.win.txt || die
+}