summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2017-01-31 09:58:51 +0100
committerAlexis Ballier <aballier@gentoo.org>2017-01-31 09:58:59 +0100
commit43bbc82386d6d9f7d227159bb5f5493cee769860 (patch)
treee6699d385f2edd9a6d5590e82356c4a653caaf10 /dev-tex/latexmk/latexmk-452c.ebuild
parentapp-arch/mt-st-1.3-r0: stable on alpha (diff)
downloadgentoo-43bbc82386d6d9f7d227159bb5f5493cee769860.tar.gz
gentoo-43bbc82386d6d9f7d227159bb5f5493cee769860.tar.bz2
gentoo-43bbc82386d6d9f7d227159bb5f5493cee769860.zip
dev-tex/latexmk: bump to 452c
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'dev-tex/latexmk/latexmk-452c.ebuild')
-rw-r--r--dev-tex/latexmk/latexmk-452c.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-tex/latexmk/latexmk-452c.ebuild b/dev-tex/latexmk/latexmk-452c.ebuild
new file mode 100644
index 000000000000..a10c1d1adf39
--- /dev/null
+++ b/dev-tex/latexmk/latexmk-452c.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit bash-completion-r1
+
+DESCRIPTION="Perl script for automatically building LaTeX documents"
+HOMEPAGE="http://www.phys.psu.edu/~collins/software/latexmk/"
+SRC_URI="http://www.phys.psu.edu/~collins/software/latexmk/${P}.zip"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~ppc-macos ~x64-macos ~x86-macos"
+
+RDEPEND="virtual/latex-base
+ dev-lang/perl"
+DEPEND="${RDEPEND}
+ app-arch/unzip"
+
+S="${WORKDIR}/${PN}"
+
+src_install() {
+ newbin latexmk.pl latexmk
+ doman latexmk.1
+ dodoc CHANGES README latexmk.pdf latexmk.txt
+ dodoc -r example_rcfiles extra-scripts
+ newbashcomp "${FILESDIR}"/completion.bash-2 ${PN}
+}