summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJonas Stein <jstein@gentoo.org>2019-06-24 10:00:03 +0200
committerJonas Stein <jstein@gentoo.org>2019-06-24 10:00:03 +0200
commit8345dada22826d4ae59c65e8746255d687f83185 (patch)
treedd0601337e8934634b588041246686e01c7185ef /dev-tex/latexmk/latexmk-465.ebuild
parentpackage.mask: Last rite media-sound/sfc (diff)
downloadgentoo-8345dada22826d4ae59c65e8746255d687f83185.tar.gz
gentoo-8345dada22826d4ae59c65e8746255d687f83185.tar.bz2
gentoo-8345dada22826d4ae59c65e8746255d687f83185.zip
dev-tex/latexmk: Version bump
Version bump to 465 (4.65). Closes: https://bugs.gentoo.org/686936 Package-Manager: Portage-2.3.67, Repoman-2.3.14 Signed-off-by: Jonas Stein <jstein@gentoo.org>
Diffstat (limited to 'dev-tex/latexmk/latexmk-465.ebuild')
-rw-r--r--dev-tex/latexmk/latexmk-465.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-tex/latexmk/latexmk-465.ebuild b/dev-tex/latexmk/latexmk-465.ebuild
new file mode 100644
index 000000000000..79b8be565a2d
--- /dev/null
+++ b/dev-tex/latexmk/latexmk-465.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit bash-completion-r1
+
+DESCRIPTION="Perl script for automatically building LaTeX documents"
+HOMEPAGE="http://www.phys.psu.edu/~collins/software/latexmk/"
+SRC_URI="http://www.phys.psu.edu/~collins/software/latexmk/${P}.zip"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~ppc-macos ~x64-macos ~x86-macos"
+
+RDEPEND="virtual/latex-base
+ dev-lang/perl"
+DEPEND="${RDEPEND}
+ app-arch/unzip"
+
+S="${WORKDIR}/${PN}"
+
+src_install() {
+ newbin latexmk.pl latexmk
+ doman latexmk.1
+ dodoc CHANGES README latexmk.pdf latexmk.txt
+ dodoc -r example_rcfiles extra-scripts
+ newbashcomp "${FILESDIR}"/completion.bash-2 ${PN}
+}