summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJonas Rabenstein <jonas.rabenstein@studium.uni-erlangen.de>2016-03-06 14:54:56 +0100
committerPatrice Clement <monsieurp@gentoo.org>2016-03-11 15:59:23 +0000
commit2083a93615b0b4baa8b0e4c11cd244ed6ddf9296 (patch)
tree30c4fe42401eb5022c18662c6aa346d4ef7f501c /dev-tex/minted/minted-2.1.ebuild
parenttoolchain-binutils.eclass: use versioned SLOT all the time (diff)
downloadgentoo-2083a93615b0b4baa8b0e4c11cd244ed6ddf9296.tar.gz
gentoo-2083a93615b0b4baa8b0e4c11cd244ed6ddf9296.tar.bz2
gentoo-2083a93615b0b4baa8b0e4c11cd244ed6ddf9296.zip
dev-tex/minted: fix compilation of documentation
Compiling of documentation currently failed, as -shell-escape was not passed to pdflatex. With recent change in latex-package.eclass (f6082c5) it is now possible to add this flag and therefore compile the documentation. Moreover in minted-2.1 there is an extra curly brace in minted.dtx which leads to a compile failure also with -shell-escape specified. Until it is fixed upstream, I added a patch to remove this extra curly brace. Closes: https://github.com/gentoo/gentoo/pull/986 Acked-by: Alexis Ballier <aballier@gentoo.org> Signed-off-by: Patrice Clement <monsieurp@gentoo.org>
Diffstat (limited to 'dev-tex/minted/minted-2.1.ebuild')
-rw-r--r--dev-tex/minted/minted-2.1.ebuild7
1 files changed, 6 insertions, 1 deletions
diff --git a/dev-tex/minted/minted-2.1.ebuild b/dev-tex/minted/minted-2.1.ebuild
index 07ed452c0c3b..99db1e44e441 100644
--- a/dev-tex/minted/minted-2.1.ebuild
+++ b/dev-tex/minted/minted-2.1.ebuild
@@ -4,7 +4,7 @@
EAPI=5
-inherit latex-package
+inherit latex-package eutils
DESCRIPTION="LaTeX package for source code syntax highlighting"
HOMEPAGE="https://github.com/gpoore/minted"
@@ -22,7 +22,12 @@ RDEPEND="
S="${WORKDIR}"/${P}/source
+src_prepare() {
+ epatch "${FILESDIR}/minted-2.1-remove-extra-curly-brace.patch"
+}
+
src_install() {
+ LATEX_DOC_ARGUMENTS='-shell-escape'
latex-package_src_install
dodoc "${S}"/../*md
}