summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-tex/pgf
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-tex/pgf')
-rw-r--r--dev-tex/pgf/Manifest2
-rw-r--r--dev-tex/pgf/metadata.xml8
-rw-r--r--dev-tex/pgf/pgf-2.10.ebuild41
-rw-r--r--dev-tex/pgf/pgf-3.0.0.ebuild39
4 files changed, 90 insertions, 0 deletions
diff --git a/dev-tex/pgf/Manifest b/dev-tex/pgf/Manifest
new file mode 100644
index 000000000000..99e88bd31e57
--- /dev/null
+++ b/dev-tex/pgf/Manifest
@@ -0,0 +1,2 @@
+DIST pgf_2.10.tds.zip 6943790 SHA256 6d197e2a6a7bdadc81d180ef58ad2ef3e446fb07e05ac52821047d8c31b90b95 SHA512 d10385a259cf5100a5c3929b48f007b796e1313730e579748fb1f6afa0957320867a000dc54edd7595f9d84926adb7b28fd7be079fed32d12bf6aee00294b16b WHIRLPOOL bfe770bbd775ec607cfbe48051a4d08e0d936afa98e075d43f70de1bfa61bbcaf5e591988b16cc9d6bfb8bffab749d74fc0b2e9ddeb127485e7075cdeac2532e
+DIST pgf_3.0.0.tds.zip 11384771 SHA256 672b15d0a73fcaee1efefdaf396db1d8313e08d91db9b15bfde293eb6132474e SHA512 c0d801855e9fb0325a4caf4dbdf30c82a39b8f2543234f04127355dc5eb22493bbe95c6d9757df122bf80ccb07f6d5a92736a3a8f67523b3a43115b6a9ae1f56 WHIRLPOOL c451b562daf3b2aa8d6fce9852d7db3a5c34a449ec544dec7865587f4281c203b40275e184f82812f49365c075f51387115d026274833713fc96958c528dd98e
diff --git a/dev-tex/pgf/metadata.xml b/dev-tex/pgf/metadata.xml
new file mode 100644
index 000000000000..b24594832686
--- /dev/null
+++ b/dev-tex/pgf/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>tex</herd>
+ <upstream>
+ <remote-id type="sourceforge">pgf</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-tex/pgf/pgf-2.10.ebuild b/dev-tex/pgf/pgf-2.10.ebuild
new file mode 100644
index 000000000000..3d5552b2ca96
--- /dev/null
+++ b/dev-tex/pgf/pgf-2.10.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit latex-package
+
+DESCRIPTION="pgf -- The TeX Portable Graphic Format"
+HOMEPAGE="http://sourceforge.net/projects/pgf"
+SRC_URI="mirror://sourceforge/pgf/${PN}_${PV}.tds.zip"
+
+LICENSE="GPL-2 LPPL-1.3c FDL-1.2"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 s390 sh sparc x86 ~amd64-fbsd ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+IUSE="doc source"
+
+RDEPEND="dev-texlive/texlive-latexrecommended
+ >=dev-tex/xcolor-2.11"
+DEPEND="${RDEPEND}
+ app-arch/unzip"
+
+TEXMF="/usr/share/texmf-site"
+S=${WORKDIR}
+
+src_install() {
+ insinto ${TEXMF}
+ doins -r tex || die
+
+ if use source ; then
+ doins -r source || die
+ fi
+
+ cd "${S}/doc/generic/pgf"
+ dodoc AUTHORS ChangeLog README TODO licenses/LICENSE || die
+ if use doc ; then
+ insinto /usr/share/doc/${PF}
+ doins pgfmanual.pdf || die
+ doins -r images macros text-en version-for-dvipdfm version-for-dvips \
+ version-for-pdftex version-for-tex4ht version-for-vtex || die \
+ "Failed to install documentation"
+ fi
+}
diff --git a/dev-tex/pgf/pgf-3.0.0.ebuild b/dev-tex/pgf/pgf-3.0.0.ebuild
new file mode 100644
index 000000000000..57c390eac4e8
--- /dev/null
+++ b/dev-tex/pgf/pgf-3.0.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit latex-package
+
+DESCRIPTION="pgf -- The TeX Portable Graphic Format"
+HOMEPAGE="http://sourceforge.net/projects/pgf"
+SRC_URI="mirror://sourceforge/pgf/${PN}_${PV}.tds.zip"
+
+LICENSE="GPL-2 LPPL-1.3c FDL-1.2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+IUSE="doc source"
+
+RDEPEND="dev-texlive/texlive-latexrecommended
+ >=dev-tex/xcolor-2.11"
+DEPEND="${RDEPEND}
+ app-arch/unzip"
+
+S=${WORKDIR}
+
+src_install() {
+ insinto ${TEXMF}
+ doins -r tex || die
+
+ if use source ; then
+ doins -r source || die
+ fi
+
+ cd "${S}/doc/generic/pgf"
+ dodoc AUTHORS ChangeLog README || die
+ if use doc ; then
+ insinto /usr/share/doc/${PF}/texdoc
+ doins pgfmanual.pdf || die
+ doins -r images macros text-en version-* || die
+ dosym /usr/share/doc/${PF}/texdoc ${TEXMF}/doc/latex/${PN} || die
+ fi
+}