summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAaron Bauman <bman@gentoo.org>2019-11-09 16:16:38 -0500
committerAaron Bauman <bman@gentoo.org>2019-11-09 16:17:57 -0500
commit5f009ba1dcab785e573a1106809c2e27d1d22159 (patch)
tree483e22dee99e1fc5d965c1a0dfc0718269c0a05b /dev-tex/sketch/sketch-0.3.7.ebuild
parentdev-util/xxdiff: use 'dodoc' (diff)
downloadgentoo-5f009ba1dcab785e573a1106809c2e27d1d22159.tar.gz
gentoo-5f009ba1dcab785e573a1106809c2e27d1d22159.tar.bz2
gentoo-5f009ba1dcab785e573a1106809c2e27d1d22159.zip
dev-tex/sketch: bump EAPI and stuff
Closes: https://bugs.gentoo.org/686504 Signed-off-by: Aaron Bauman <bman@gentoo.org>
Diffstat (limited to 'dev-tex/sketch/sketch-0.3.7.ebuild')
-rw-r--r--dev-tex/sketch/sketch-0.3.7.ebuild37
1 files changed, 19 insertions, 18 deletions
diff --git a/dev-tex/sketch/sketch-0.3.7.ebuild b/dev-tex/sketch/sketch-0.3.7.ebuild
index a5e77a7f4405..2e24cc537c14 100644
--- a/dev-tex/sketch/sketch-0.3.7.ebuild
+++ b/dev-tex/sketch/sketch-0.3.7.ebuild
@@ -1,45 +1,46 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=0
+EAPI=7
inherit eutils toolchain-funcs
DESCRIPTION="Produces drawings of two- or three-dimensional solid objects and scenes for TeX"
-HOMEPAGE="http://www.frontiernet.net/~eugene.ressler/"
-SRC_URI="http://www.frontiernet.net/~eugene.ressler/${P}.tgz"
-LICENSE="GPL-3"
+HOMEPAGE="https://www.frontiernet.net/~eugene.ressler/"
+SRC_URI="https://www.frontiernet.net/~eugene.ressler/${P}.tgz"
-SLOT="0"
KEYWORDS="~amd64 ~ppc64 ~x86"
+
+LICENSE="GPL-3+"
+SLOT="0"
IUSE="doc examples"
DEPEND="dev-lang/perl"
RDEPEND=""
-src_unpack() {
- unpack ${A}
-
- cd "${S}"
- sed -i -e "s:\$(CC):\$(CC) \$(LDFLAGS):" makefile
+src_prepare() {
+ sed -i -e "s:\$(CC):\$(CC) \$(LDFLAGS):" makefile || die "Fixing Makefile failed"
+ eapply_user
}
src_compile() {
- emake CC="$(tc-getCC)" LDFLAGS="${LDFLAGS}" || die "emake failed"
+ emake CC="$(tc-getCC)" LDFLAGS="${LDFLAGS}"
}
src_install() {
- dobin sketch || die
+ dobin sketch
edos2unix Doc/sketch.info
- doinfo Doc/sketch.info || die
- dohtml updates.htm || die
+ doinfo Doc/sketch.info
+ dodoc -r updates.htm
+
if use doc ; then
insinto /usr/share/doc/${PF}
- doins Doc/sketch.pdf || die
- dohtml Doc/sketch/* || die
+ doins Doc/sketch.pdf
+ dodoc -r Doc/sketch/*
fi
+
if use examples ; then
insinto /usr/share/doc/${PF}/examples
- doins Data/* || die "Failed to install examples"
+ doins Data/*
fi
}