summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2016-09-26 21:52:33 +0200
committerManuel Rüger <mrueg@gentoo.org>2016-09-26 21:52:33 +0200
commit02371369312cf0b6cff2283235934ff21f1353dc (patch)
tree681ec289cb9b9d9584ac73bc9341a6d78d211260 /dev-tex
parentdev-tex/biblatex: Remove old (diff)
downloadgentoo-02371369312cf0b6cff2283235934ff21f1353dc.tar.gz
gentoo-02371369312cf0b6cff2283235934ff21f1353dc.tar.bz2
gentoo-02371369312cf0b6cff2283235934ff21f1353dc.zip
dev-tex/biblatex: Depend on dev-texlive/texlive-genericextra
Gentoo-Bug: 585856 Package-Manager: portage-2.3.1
Diffstat (limited to 'dev-tex')
-rw-r--r--dev-tex/biblatex/biblatex-3.4-r1.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-tex/biblatex/biblatex-3.4-r1.ebuild b/dev-tex/biblatex/biblatex-3.4-r1.ebuild
new file mode 100644
index 000000000000..114854ae6fb9
--- /dev/null
+++ b/dev-tex/biblatex/biblatex-3.4-r1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit latex-package
+
+DESCRIPTION="Reimplementation of the bibliographic facilities provided by LaTeX"
+HOMEPAGE="http://www.ctan.org/tex-archive/macros/latex/contrib/biblatex https://github.com/plk/biblatex/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tds.tgz"
+
+LICENSE="LPPL-1.3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="doc examples"
+
+RDEPEND="dev-texlive/texlive-bibtexextra
+ dev-texlive/texlive-latexextra
+ dev-texlive/texlive-genericextra"
+DEPEND="${RDEPEND}"
+
+S=${WORKDIR}
+TEXMF=/usr/share/texmf-site
+
+src_install() {
+ insinto "${TEXMF}"
+ doins -r bibtex tex
+
+ dodoc doc/latex/biblatex/{README,CHANGES}
+ use doc && { pushd doc/ ; latex-package_src_doinstall doc ; popd ; }
+ if use examples ; then
+ docinto examples
+ dodoc -r doc/latex/biblatex/examples
+ fi
+}