summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakov Smolić <jsmolic@gentoo.org>2023-06-22 15:11:01 +0200
committerJakov Smolić <jsmolic@gentoo.org>2023-06-22 15:11:01 +0200
commit7908c063e8df3d4f4ba6d0b6eb428df9df5e7dd0 (patch)
treedc28953e75b79b85eb65506ddaa388e6f5e2053a /dev-tex
parentgames-emulation/pcsxr: treeclean (diff)
downloadgentoo-7908c063e8df3d4f4ba6d0b6eb428df9df5e7dd0.tar.gz
gentoo-7908c063e8df3d4f4ba6d0b6eb428df9df5e7dd0.tar.bz2
gentoo-7908c063e8df3d4f4ba6d0b6eb428df9df5e7dd0.zip
dev-tex/cpp2latex: treeclean
Signed-off-by: Jakov Smolić <jsmolic@gentoo.org>
Diffstat (limited to 'dev-tex')
-rw-r--r--dev-tex/cpp2latex/Manifest1
-rw-r--r--dev-tex/cpp2latex/cpp2latex-2.3-r2.ebuild19
-rw-r--r--dev-tex/cpp2latex/files/cpp2latex-2.3-gcc43.patch12
-rw-r--r--dev-tex/cpp2latex/files/cpp2latex-2.3-tests.patch15
-rw-r--r--dev-tex/cpp2latex/files/cpp2latex-2.3.patch44
-rw-r--r--dev-tex/cpp2latex/metadata.xml8
6 files changed, 0 insertions, 99 deletions
diff --git a/dev-tex/cpp2latex/Manifest b/dev-tex/cpp2latex/Manifest
deleted file mode 100644
index 30367b7b5760..000000000000
--- a/dev-tex/cpp2latex/Manifest
+++ /dev/null
@@ -1 +0,0 @@
-DIST cpp2latex-2.3.tar.gz 483213 BLAKE2B eed33201db3a2144d59d200386e44976f6c7e7b621516c23ac35c195f7fa64d65cd156ef6a4d610dffaab62ca62cc73ab1894cc8bf94284e61375be44ad6ad06 SHA512 af4a13a79b2eb14556f35ca372a0c4f5fec5ddc52a712e998fb73dfe0451c1d95eb857f905a9fd66fac72f734fdcad50b9bca2769780950c7b04fa56912812e1
diff --git a/dev-tex/cpp2latex/cpp2latex-2.3-r2.ebuild b/dev-tex/cpp2latex/cpp2latex-2.3-r2.ebuild
deleted file mode 100644
index fdf89e105561..000000000000
--- a/dev-tex/cpp2latex/cpp2latex-2.3-r2.ebuild
+++ /dev/null
@@ -1,19 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-DESCRIPTION="A program to convert C++ code to LaTeX source"
-HOMEPAGE="http://www.arnoldarts.de/cpp2latex/"
-SRC_URI="http://www.arnoldarts.de/files/cpp2latex/${P}.tar.gz"
-LICENSE="GPL-2"
-
-SLOT="0"
-KEYWORDS="amd64 ppc sparc x86"
-
-# first patch: bug #44585, second patch bug #227863
-PATCHES=(
- "${FILESDIR}/${P}.patch"
- "${FILESDIR}/${P}-gcc43.patch"
- "${FILESDIR}/${P}-tests.patch"
-)
diff --git a/dev-tex/cpp2latex/files/cpp2latex-2.3-gcc43.patch b/dev-tex/cpp2latex/files/cpp2latex-2.3-gcc43.patch
deleted file mode 100644
index 006560506676..000000000000
--- a/dev-tex/cpp2latex/files/cpp2latex-2.3-gcc43.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-Index: cpp2latex-2.3/cpp2latex/main.cpp
-===================================================================
---- cpp2latex-2.3.orig/cpp2latex/main.cpp
-+++ cpp2latex-2.3/cpp2latex/main.cpp
-@@ -22,6 +22,7 @@
- #include <iostream>
- #include <stdlib.h>
- #include <string>
-+#include <cstring>
- #include <fstream>
- #include <vector>
- #include <stdio.h>
diff --git a/dev-tex/cpp2latex/files/cpp2latex-2.3-tests.patch b/dev-tex/cpp2latex/files/cpp2latex-2.3-tests.patch
deleted file mode 100644
index 621c43d28156..000000000000
--- a/dev-tex/cpp2latex/files/cpp2latex-2.3-tests.patch
+++ /dev/null
@@ -1,15 +0,0 @@
-Index: cpp2latex-2.3/cpp2latex/getopttest.cpp
-===================================================================
---- cpp2latex-2.3.orig/cpp2latex/getopttest.cpp
-+++ cpp2latex-2.3/cpp2latex/getopttest.cpp
-@@ -2,7 +2,9 @@
- #include <iostream>
- #include <getopt.h>
-
--void main( int argc, char* argv[] )
-+using namespace std;
-+
-+int main( int argc, char* argv[] )
- {
- int optch=0, optc=1;
- while( ( optch = getopt( argc,argv, "h:a:k" ) ) > 0 )
diff --git a/dev-tex/cpp2latex/files/cpp2latex-2.3.patch b/dev-tex/cpp2latex/files/cpp2latex-2.3.patch
deleted file mode 100644
index b72b870ba53b..000000000000
--- a/dev-tex/cpp2latex/files/cpp2latex-2.3.patch
+++ /dev/null
@@ -1,44 +0,0 @@
---- a/cpp2latex/main.cpp Thu Mar 6 08:15:36 2003
-+++ a/cpp2latex/main.cpp Tue Jan 24 21:47:17 2006
-@@ -27,12 +27,14 @@
- #include <stdio.h>
- #include <getopt.h>
-
-+using namespace std;
-+
- struct replace{
- std::string voraus;
- std::string ersetzt;
- };
-
--std::vector <replace> rules;
-+std::vector<struct replace> rules;
- std::string syntax( std::ifstream *src, char *c );
- void initReplace();
- bool satzzeichen( char c );
-@@ -162,9 +164,13 @@
- if( comment && !comment1 )
- {
- file.get(c);
-- if(c=='/') { out+="/}"; comment=false; }
-- else { if(c=='\n') out+="\\\\"; }
-- if( !( (c=='*')||(c=='/') )) out+=c;
-+ if(c=='/') {
-+ out+="/}";
-+ comment=false;
-+ } else if (c=='\n') out+="\\\\";
-+ /* .alex. 1 line substitution*/
-+ else file.seekg(-1,ios::cur);
-+ //if( !( (c=='*')||(c=='/') )) out+=c;
- }
- break;
-
-@@ -323,7 +329,7 @@
- /** initialize the replacementrules */
- void initReplace()
- {
--replace dummy;
-+ struct replace dummy;
- dummy.voraus = "and"; dummy.ersetzt = "\\textbf{and}"; rules.push_back(dummy);
- dummy.voraus = "and_eq"; dummy.ersetzt = "\\textbf{and\\underline\\ eq}"; rules.push_back(dummy);
- dummy.voraus = "asm"; dummy.ersetzt = "\\textbf{asm}"; rules.push_back(dummy);
diff --git a/dev-tex/cpp2latex/metadata.xml b/dev-tex/cpp2latex/metadata.xml
deleted file mode 100644
index edfe97231997..000000000000
--- a/dev-tex/cpp2latex/metadata.xml
+++ /dev/null
@@ -1,8 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
-<maintainer type="project">
- <email>tex@gentoo.org</email>
- <name>Gentoo TeX Project</name>
-</maintainer>
-</pkgmetadata>