summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMario Haustein <mario.haustein@hrz.tu-chemnitz.de>2023-03-15 21:31:31 +0100
committerSam James <sam@gentoo.org>2023-03-19 03:13:00 +0000
commit78cc343bda4715a370c177bdfb5486b0d9024236 (patch)
tree82e49f845ba000f49a5185bdba7f615f39a172fa /dev-util/ROPgadget
parentdev-util/ROPgadget: drop 7.1 (diff)
downloadgentoo-78cc343bda4715a370c177bdfb5486b0d9024236.tar.gz
gentoo-78cc343bda4715a370c177bdfb5486b0d9024236.tar.bz2
gentoo-78cc343bda4715a370c177bdfb5486b0d9024236.zip
dev-util/ROPgadget: add 7.3
Signed-off-by: Mario Haustein <mario.haustein@hrz.tu-chemnitz.de> Closes: https://github.com/gentoo/gentoo/pull/30145 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-util/ROPgadget')
-rw-r--r--dev-util/ROPgadget/Manifest1
-rw-r--r--dev-util/ROPgadget/ROPgadget-7.3.ebuild35
2 files changed, 36 insertions, 0 deletions
diff --git a/dev-util/ROPgadget/Manifest b/dev-util/ROPgadget/Manifest
index 4bc6c6653fa3..33dff96845b8 100644
--- a/dev-util/ROPgadget/Manifest
+++ b/dev-util/ROPgadget/Manifest
@@ -1 +1,2 @@
DIST ROPgadget-7.2.gh.tar.gz 10092747 BLAKE2B 1a1de7ce06115c8ffb377d3e7c77a268d3e9a158ed9255c02f954da4a0c32732f741e7ca081fa0b75b9a5dce2fa099b8548f26d248ed0285a2290f88dadc848d SHA512 cc3f87a4a331a3c7799f197b8a9056d1da85697a47c57d03cc080aa61d6c8a00775e7f972082f92451439c36ef9d820c982194464f02ec041b5bbeb97fa26f9a
+DIST ROPgadget-7.3.gh.tar.gz 10105592 BLAKE2B b5bfa7bbac6875c2a417c65f3415603c07fda64f96416bba7fc4d6ea653c81b97b7dc4d8573ad53f3353862a218afb15aeaf238880d82a568b6cbe1bb276eb99 SHA512 58457f77c24a1cc4cc703c75aed9303f63ce3eba699210239603e274f134ec06d73b2c519b78176fcaaf6794a81c5a59bb9bafeaa429f7085443372e1087e173
diff --git a/dev-util/ROPgadget/ROPgadget-7.3.ebuild b/dev-util/ROPgadget/ROPgadget-7.3.ebuild
new file mode 100644
index 000000000000..ec2cad9d2931
--- /dev/null
+++ b/dev-util/ROPgadget/ROPgadget-7.3.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+PYTHON_REQ_USE="sqlite"
+
+inherit distutils-r1
+
+DESCRIPTION="Search for gadgets in binaries to facilitate your ROP exploitation"
+HOMEPAGE="https://shell-storm.org/project/ROPgadget/"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/JonathanSalwan/ROPgadget"
+else
+ SRC_URI="https://github.com/JonathanSalwan/ROPgadget/archive/v${PV}.tar.gz -> ${P}.gh.tar.gz"
+ KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
+fi
+
+LICENSE="GPL-2"
+SLOT="0"
+
+RDEPEND="
+ ${PYTHON_DEPS}
+ >=dev-libs/capstone-5[python,${PYTHON_USEDEP}]
+"
+
+src_test() {
+ pushd test-suite-binaries || die
+ ./test.sh || die
+ popd || die
+}