summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2018-05-16 09:13:35 +0200
committerMichał Górny <mgorny@gentoo.org>2018-05-16 09:26:17 +0200
commitaf9424bbd6fee57344de4fa8cdb4806ce20ae1e5 (patch)
tree5da1317a914a49c50d732624d225acd8b6cde88e /dev-util/abi-compliance-checker/abi-compliance-checker-2.3.ebuild
parentdev-util/abi-compliance-checker: Remove crazy stuff from -9999 (diff)
downloadgentoo-af9424bbd6fee57344de4fa8cdb4806ce20ae1e5.tar.gz
gentoo-af9424bbd6fee57344de4fa8cdb4806ce20ae1e5.tar.bz2
gentoo-af9424bbd6fee57344de4fa8cdb4806ce20ae1e5.zip
dev-util/abi-compliance-checker: Bump to 2.3
Diffstat (limited to 'dev-util/abi-compliance-checker/abi-compliance-checker-2.3.ebuild')
-rw-r--r--dev-util/abi-compliance-checker/abi-compliance-checker-2.3.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-util/abi-compliance-checker/abi-compliance-checker-2.3.ebuild b/dev-util/abi-compliance-checker/abi-compliance-checker-2.3.ebuild
new file mode 100644
index 000000000000..e821544b1a85
--- /dev/null
+++ b/dev-util/abi-compliance-checker/abi-compliance-checker-2.3.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="A tool for checking backward compatibility of a C/C++ library"
+HOMEPAGE="http://ispras.linuxbase.org/index.php/ABI_compliance_checker"
+SRC_URI="https://github.com/lvc/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="dev-lang/perl"
+RDEPEND="${DEPEND}
+ dev-util/abi-dumper
+ dev-util/ctags"
+
+src_install() {
+ dodir /usr
+ perl Makefile.pl --install --prefix="${EPREFIX}"/usr --destdir="${D}" || die
+ einstalldocs
+}