summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-util/android-sdk-update-manager/android-sdk-update-manager-21.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-util/android-sdk-update-manager/android-sdk-update-manager-21.ebuild')
-rw-r--r--dev-util/android-sdk-update-manager/android-sdk-update-manager-21.ebuild100
1 files changed, 100 insertions, 0 deletions
diff --git a/dev-util/android-sdk-update-manager/android-sdk-update-manager-21.ebuild b/dev-util/android-sdk-update-manager/android-sdk-update-manager-21.ebuild
new file mode 100644
index 000000000000..fa0e573292db
--- /dev/null
+++ b/dev-util/android-sdk-update-manager/android-sdk-update-manager-21.ebuild
@@ -0,0 +1,100 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils user
+
+MY_P="android-sdk_r${PV}-linux"
+
+DESCRIPTION="Open Handset Alliance's Android SDK"
+HOMEPAGE="http://developer.android.com"
+SRC_URI="http://dl.google.com/android/${MY_P}.tgz"
+IUSE=""
+RESTRICT="mirror"
+
+LICENSE="android"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="app-arch/tar
+ app-arch/gzip"
+RDEPEND="
+ >=virtual/jdk-1.5
+ >=dev-java/ant-core-1.6.5
+ >=dev-java/swt-3.5[cairo]
+ >=x11-libs/gtk+-2.24.23-r2:2[abi_x86_32(-)]
+"
+
+ANDROID_SDK_DIR="/opt/${PN}"
+QA_FLAGS_IGNORED_x86="
+ ${ANDROID_SDK_DIR/\/}/tools/emulator
+ ${ANDROID_SDK_DIR/\/}/tools/adb
+ ${ANDROID_SDK_DIR/\/}/tools/mksdcard
+ ${ANDROID_SDK_DIR/\/}/tools/sqlite3
+ ${ANDROID_SDK_DIR/\/}/tools/hprof-conv
+ ${ANDROID_SDK_DIR/\/}/tools/zipalign
+ ${ANDROID_SDK_DIR/\/}/tools/dmtracedump
+"
+QA_FLAGS_IGNORED_amd64="${QA_FLAGS_IGNORED_x86}"
+
+QA_PREBUILT="${ANDROID_SDK_DIR/\/}/tools/*"
+
+S="${WORKDIR}/android-sdk-linux"
+
+pkg_setup() {
+ enewgroup android
+}
+
+src_prepare(){
+ rm -rf tools/lib/x86*
+}
+
+src_install(){
+ dodoc tools/NOTICE.txt "SDK Readme.txt"
+ rm -f tools/NOTICE.txt "SDK Readme.txt"
+
+ dodir "${ANDROID_SDK_DIR}/tools"
+ cp -pPR tools/* "${ED}${ANDROID_SDK_DIR}/tools" || die "failed to install tools"
+
+ # Maybe this is needed for the tools directory too.
+ dodir "${ANDROID_SDK_DIR}"/{add-ons,docs,platforms,temp}
+
+ fowners root:android "${ANDROID_SDK_DIR}"/{,add-ons,docs,platforms,temp,tools} || die
+ fperms 0775 "${ANDROID_SDK_DIR}"/{,add-ons,docs,platforms,temp,tools} || die
+
+ echo "PATH=\"${EPREFIX}${ANDROID_SDK_DIR}/tools:${EPREFIX}${ANDROID_SDK_DIR}/platform-tools\"" > "${T}/80${PN}" || die
+
+ SWT_PATH=
+ SWT_VERSIONS="4.2 3.7 3.6 3.5"
+ for version in $SWT_VERSIONS; do
+ # redirecting stderr to /dev/null
+ # not sure if this is best, but avoids misleading error messages
+ SWT_PATH="`dirname \`java-config -p swt-\$version 2>/dev/null\` 2>/dev/null`"
+ if [ $SWT_PATH ]; then
+ einfo "SWT_PATH=$SWT_PATH selecting version $version of SWT."
+ break
+ fi
+ done
+
+ echo "ANDROID_SWT=\"${SWT_PATH}\"" >> "${T}/80${PN}" || die
+
+ doenvd "${T}/80${PN}"
+
+ echo "SEARCH_DIRS_MASK=\"${EPREFIX}${ANDROID_SDK_DIR}\"" > "${T}/80${PN}" || die
+
+ insinto "/etc/revdep-rebuild" && doins "${T}/80${PN}"
+}
+
+pkg_postinst() {
+ elog "The Android SDK now uses its own manager for the development environment."
+ elog "Run 'android' to download the full SDK, including some of the platform tools."
+ elog "You must be in the android group to manage the development environment."
+ elog "Just run 'gpasswd -a <USER> android', then have <USER> re-login."
+ elog "See http://developer.android.com/sdk/adding-components.html for more"
+ elog "information."
+ elog "If you have problems downloading the SDK, see http://code.google.com/p/android/issues/detail?id=4406"
+ elog "You need to run env-update and source /etc/profile in any open shells"
+ elog "if you get an SWT error."
+}