summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2015-11-14 18:59:15 +0100
committerPacho Ramos <pacho@gentoo.org>2015-11-14 19:38:50 +0100
commit5524bc4e11af753fd75df04997d768723c905acb (patch)
tree7ffbff6b9d3a40c7331fd0348036e047f89a38ac /dev-util/anjuta
parentdev-python/pygobject: Drop old (diff)
downloadgentoo-5524bc4e11af753fd75df04997d768723c905acb.tar.gz
gentoo-5524bc4e11af753fd75df04997d768723c905acb.tar.bz2
gentoo-5524bc4e11af753fd75df04997d768723c905acb.zip
dev-util/anjuta: Version bump
Package-Manager: portage-2.2.24
Diffstat (limited to 'dev-util/anjuta')
-rw-r--r--dev-util/anjuta/Manifest1
-rw-r--r--dev-util/anjuta/anjuta-3.18.2.ebuild137
2 files changed, 138 insertions, 0 deletions
diff --git a/dev-util/anjuta/Manifest b/dev-util/anjuta/Manifest
index c19130a5b1cc..8aede7a8907b 100644
--- a/dev-util/anjuta/Manifest
+++ b/dev-util/anjuta/Manifest
@@ -1,2 +1,3 @@
DIST anjuta-3.14.1.tar.xz 6310008 SHA256 b26cd75ddb603c3cca4348e277d17360e511d75bd77ee2ef52047b75408e617b SHA512 474e5db8799c99645314c8822b97c375f91102d6617e2b8d5e3d856df5d51e11508ca76405ee333a1c208255b98c90c2816de0f2df9f70523d98a2aa0aa3837e WHIRLPOOL 928d6eefca146869a1e7ff004e0f4a990789758416e7209fa62e9dac8b1eafe53ee61d2c6a41d4dfc847cbd3411bd4032a12d3741287488438d6339cabbd459c
DIST anjuta-3.16.0.tar.xz 6311980 SHA256 77432a01b37b46f5558bf4cc435f9a023abf17c5273d472e17dff1f9b3d9943c SHA512 c679ed615f4e8163bcb8857a8f3865bd7db983995e3cf944a0450926f17b805a8f622e22744c03556a43287b5fa6031465d7f8e8810abf4022a2c78dd080cdf1 WHIRLPOOL 7fc11eb4f3cf52d62ace2109b06c4a8fb4928748be5f4c6f384763d113ff64bf5c42280a4c70eab6cc67f559c36bf7b0625f94f9de2195a08734fcc5c9b93ebb
+DIST anjuta-3.18.2.tar.xz 6356972 SHA256 be864f2f1807e1b870697f646294e997d221d5984a135245543b719e501cef8e SHA512 0220f312b6c34bcaa5b4e2d0090afeb57e48b2c1f7ee050a986f0052d1b048919adc952b01b3a1b676481595f13d7c869b929d0b519ab33066703b75ccfda5f1 WHIRLPOOL e61b1745372f31639cd05516f203dd13652256aabbd6a5792654c7dd8b98ea0f12c8c8b068c2a325be6dbdbc62e9e2e149f06fc94b79d1725ae5fc36f6a905b9
diff --git a/dev-util/anjuta/anjuta-3.18.2.ebuild b/dev-util/anjuta/anjuta-3.18.2.ebuild
new file mode 100644
index 000000000000..f0f3bdefb2e2
--- /dev/null
+++ b/dev-util/anjuta/anjuta-3.18.2.ebuild
@@ -0,0 +1,137 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+GCONF_DEBUG="no"
+GNOME2_LA_PUNT="yes"
+PYTHON_COMPAT=( python2_7 )
+# libanjuta-language-vala.so links to a specific slot of libvala; we want to
+# avoid automagic behavior.
+VALA_MIN_API_VERSION="0.28"
+VALA_MAX_API_VERSION="${VALA_MIN_API_VERSION}"
+
+inherit gnome2 flag-o-matic readme.gentoo python-single-r1 vala
+
+DESCRIPTION="A versatile IDE for GNOME"
+HOMEPAGE="https://wiki.gnome.org/Apps/Anjuta"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86 ~x86-fbsd"
+
+IUSE="debug devhelp glade +introspection packagekit subversion terminal test vala"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+# FIXME: make python dependency non-automagic
+COMMON_DEPEND="
+ >=dev-libs/glib-2.34:2[dbus]
+ x11-libs/gdk-pixbuf:2
+ >=x11-libs/gtk+-3.10:3
+ >=dev-libs/libxml2-2.4.23
+ >=dev-libs/gdl-3.5.5:3=
+ >=x11-libs/gtksourceview-3:3.0
+
+ sys-devel/autogen
+
+ >=gnome-extra/libgda-5:5=
+ dev-util/ctags
+
+ x11-libs/libXext
+ x11-libs/libXrender
+
+ ${PYTHON_DEPS}
+
+ devhelp? ( >=dev-util/devhelp-3.7.4:= )
+ glade? ( >=dev-util/glade-3.12:3.10= )
+ introspection? ( >=dev-libs/gobject-introspection-0.9.5:= )
+ subversion? (
+ >=dev-vcs/subversion-1.8:=
+ >=net-libs/serf-1.2:1=
+ >=dev-libs/apr-1:=
+ >=dev-libs/apr-util-1:= )
+ terminal? ( >=x11-libs/vte-0.27.6:2.91 )
+ vala? ( $(vala_depend) )
+"
+RDEPEND="${COMMON_DEPEND}
+ gnome-base/gsettings-desktop-schemas
+ packagekit? ( app-admin/packagekit-base )
+"
+DEPEND="${COMMON_DEPEND}
+ >=dev-lang/perl-5
+ >=dev-util/gtk-doc-am-1.4
+ >=dev-util/intltool-0.40.1
+ sys-devel/bison
+ sys-devel/flex
+ >=sys-devel/gettext-0.17
+ virtual/pkgconfig
+ !!dev-libs/gnome-build
+ test? (
+ app-text/docbook-xml-dtd:4.1.2
+ app-text/docbook-xml-dtd:4.5 )
+ app-text/yelp-tools
+ dev-libs/gobject-introspection-common
+ gnome-base/gnome-common
+"
+# yelp-tools, gi-common and gnome-common are required by eautoreconf
+
+pkg_setup() {
+ python-single-r1_pkg_setup
+}
+
+src_prepare() {
+ if use vala; then
+ DISABLE_AUTOFORMATTING="yes"
+ DOC_CONTENTS="To create a generic vala project you will need to specify
+desired valac versioned binary to be used, to do that you
+will need to:
+1. Go to 'Build' -> 'Configure project'
+2. Add 'VALAC=/usr/bin/valac-X.XX' (respecting quotes) to
+'Configure options'."
+ fi
+
+ # COPYING is used in Anjuta's help/about entry
+ DOCS="AUTHORS ChangeLog COPYING FUTURE MAINTAINERS NEWS README ROADMAP THANKS TODO"
+
+ # Conflicts with -pg in a plugin, bug #266777
+ filter-flags -fomit-frame-pointer
+
+ # Do not build benchmarks, they are not installed and for dev purpose only
+ sed -e '/SUBDIRS =/ s/benchmark//' \
+ -i plugins/symbol-db/Makefile.{am,in} || die
+
+ use vala && vala_src_prepare
+ gnome2_src_prepare
+}
+
+src_configure() {
+ gnome2_src_configure \
+ --disable-neon \
+ --disable-static \
+ $(use_enable debug) \
+ $(use_enable devhelp plugin-devhelp) \
+ $(use_enable glade plugin-glade) \
+ $(use_enable glade glade-catalog) \
+ $(use_enable introspection) \
+ $(use_enable packagekit) \
+ $(use_enable subversion plugin-subversion) \
+ $(use_enable subversion serf) \
+ $(use_enable terminal plugin-terminal) \
+ $(use_enable vala)
+}
+
+src_install() {
+ # COPYING is used in Anjuta's help/about entry
+ docompress -x "/usr/share/doc/${PF}/COPYING"
+
+ # Anjuta uses a custom rule to install DOCS, get rid of it
+ gnome2_src_install
+ rm -rf "${ED}"/usr/share/doc/${PN} || die "rm failed"
+
+ use vala && readme.gentoo_create_doc
+}
+
+pkg_postinst() {
+ gnome2_pkg_postinst
+ use vala && readme.gentoo_print_elog
+}